If you are using Apache 1.3 with mod_ssl or Apache 2 with ssl built in, you are vulnerable
Any SSL using the OpenSSL libraries are at risk.

Please review this other thread

Crypto Thread