Results 1 to 6 of 6

Thread: Ethereal 0.9.15 problem

  1. #1
    AO übergeek phishphreek's Avatar
    Join Date
    Jan 2002

    ethereal 0.9.15 problem

    Note. I tried to fix the subject, but it won't change from ethereal 3.0 to .9.15... I wrote down the wrong info while posting this.

    I'm trying to install ethereal 0.9.15 and I can't get the ethernet adapters to show up in the interfaces lists.

    Windowx XP Pro sp1 with all critical updates.
    ethereal 0.9.15 winpcap_3.0

    I didn't have a version of winpcap installed before.
    I installed winpcap 3.0 first and the rebooted.

    I tried to retrieve a list of adaptes via windump.

    C:\Documents and Settings\user>windump -D
    windump: PacketGetAdapterNames: The operation completed successfully.
    Nothing showed up.

    I have unisntalled/ installed/ reboot several times.

    I installed version 2.3 of winpcap (earliest version that supports XP) and I get the same thing.

    I then installed ethreal 0.9.15 and I can't get the ethernet adapters (or any adapters for that matter) to show up in interfaces.

    From the FAQ I saw that to fix the problem, you must run it as administrator. I have installed it and run it as local admin on a local machine, and also as domain admin on the domiain login.

    From the FAQ:

    Q 5.25: Does Ethereal work on Windows XP?
    Run ethereal as admin if adapters don't show up under interfaces.

    Would it matter than I have the network montior capture utility installed? This was installed from the windows xp cdrom in the /support/ folder. Just to make sure, I have removed the network monitor driver, and that didn't seem to make a difference.

    Just to make sure it wasn't a probem with the NIC, I just installed a second network adapter that also doesn't show up.

    I can get it to work just fine at home (workgroup environment), using the same network adapter and same version of Windows XP with the same updates.

    Any ideas as to why it the interfaces won't show up in the list? Or why windump can't find the interfaces either?

  2. #2
    AO Ancient: Team Leader
    Join Date
    Oct 2002
    I think this is a WinPcap issue. I had similar happen with a different packet capture utility loaded. I uninstalled the old packet capture, uninstalled WinPcap and reinstalled it and it worked fine....

    Hope this helps......
    Don\'t SYN us.... We\'ll SYN you.....
    \"A nation that draws too broad a difference between its scholars and its warriors will have its thinking done by cowards, and its fighting done by fools.\" - Thucydides

  3. #3
    Join Date
    Aug 2001
    *Thread title edited*

  4. #4
    AO übergeek phishphreek's Avatar
    Join Date
    Jan 2002
    TS: Thanks for your advise. I'll try it tomorrow. I have tried it in the process you suggested with different versions, but so far, nothing. I'll try again.

    Neg: Thanks for editing it for me.

  5. #5
    Leftie Linux Lover the_JinX's Avatar
    Join Date
    Nov 2001
    Beverwijk Netherlands
    I have never had any trouble installing or using ethereal, neither with this nor any previous version..

    But then again.. I never used the Windows version..

    btw lol @ Ethereal's "subtitle"

    Sniffing the glue that holds the Internet together
    ASCII stupid question, get a stupid ANSI.
    When in Russia, pet a PETSCII.

    Get your ass over to SLAYRadio the best station for C64 Remixes !

  6. #6
    AO übergeek phishphreek's Avatar
    Join Date
    Jan 2002
    I still can't seem to get it to work. I've tried uninstalling, rebooting, installing, etc.

    I can't get winpcap 2.3 or 3.0 to work with windump even!

    If I can get it to work with that, then it will work with ethreal.

    Any more ideas anyone?

    I know that it will work with linux... but unfortunatly, that isn't an option... unless I can find a hub somewhere around here. I think all I have are switches.

    Got it!!! Damn, that took forever. unintall, reboot, install, reboot, unintall, reboot, install, reboot, unintall, reboot, install, reboot, unintall, reboot, install, reboot... etc.

    Thanks for the suggestions/advise!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts