linux sound issue
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: linux sound issue

  1. #1
    Senior Member
    Join Date
    Jul 2002
    Posts
    123

    Question linux sound issue

    ok, so i have had red hat 9 up and running so far and i love it, but i have been unable to get any of my music to play. i downloaded xmms mp3 player so i could play some of my mp3's, no problem installing, but whenever i try to load a file and play it. xmms crashes. linux will crash to if i start messing around with the sound settings. i went into preferences > sound. and turned on the sound server, system worked for afew seconds and when i tried to play some system event sounds the whole thing went crashing down. im so stumped i duno where to begin. i've been trying to look for a new driver of soem kind but can't find any. my sound card is onboard my motherboard which is a MSI k7t266 pro 2 motherboard with onboard AC97 sound. i went to the manufacturers website, nothing for linux... help!!

  2. #2
    RH9 does not even detect my onboard sound card. I am not sure exactly what is going on. Information would be appreciated.

    -Cheers-

  3. #3
    Senior Member
    Join Date
    Sep 2003
    Posts
    279
    I'm having the exact problem with RH9 and knoppix 3.3
    AntiOnline Quick Forum Version 2b Click Here
    10010101000000110010001100111

  4. #4
    Banned
    Join Date
    Nov 2003
    Posts
    34
    Its a bug you jackass's no offense Im the SuSE master!!!
    *joking*
    Heres a link I hope it helps
    HERE

  5. #5
    @ŞΜĮЙǐЅŦГǻţΩЯ D0pp139an93r's Avatar
    Join Date
    May 2003
    Location
    St. Petersburg, FL
    Posts
    1,689
    I know that there are RH device drivers for various sound cards out there, but they take some searching. Unfortunately RH 9 is the last in it's line, so we can't expect any support on that end. What you might try is poking around various Linux sites, the ones concerning Linux in general.

    www.linuxgeeks.com
    www.linux.org

    These sites may not have the answer but they could point you to it.

    Have you checked the tech forums on www.yoursincyberspace.com?

    EDIT: As a suggestion for the undetected onboard sound, that happened to me once, turns out it was disabled in the BIOS. You might check that. If not, it may just be RH. It doesn't always detect things.
    Real security doesn't come with an installer.

  6. #6
    Senior Member
    Join Date
    Jul 2002
    Posts
    123
    well the thing is, when i goto system setting sand goto "detect sound card" it has the correct sound card information, and when i first boot and goto this optiond and click "play test sound" i hear the test sound fine. but when i start up gaim and i hear a sound or 2 from it, or when i attempt to play a file in XMMS all sound ceases to function, yes very wierd indeed, i have tried looking around for 3 hours now for possibly soutions on the web, but they were all greek to me and incredibly complicated, if anyone could possibly point me in the right direction i would be greatful
    speak your mind becuase those who matter don\'t mind and those who mind don\'t matter

  7. #7
    Senior Member
    Join Date
    Mar 2003
    Posts
    245
    Hi Alphaflux,

    First thing to know is that mp3 ability via XMMS and friends (all using vorbis) is stripped and intentionally does not work in RH 8 and RH9, and will more likely than not continue to be that way. Applications that use mpg321 should work fine (such as gqmpeg) for playing mp3's.

    As to your sound card, what model do you have? Ensonique, Sound Blaster compatible, and Sound Blaster Live! 5.1 cards (driver emu10k) all work fine in my experience. You might check dmesg ( e.g. dmesg | more) and see if anything is being picked up that references a device that is your sound card.

    -- spurious
    Get OpenSolaris http://www.opensolaris.org/

  8. #8
    Senior Member
    Join Date
    Jul 2002
    Posts
    123
    as i said before, its just a standard onboard soundcard ac97 via8233 chipset
    speak your mind becuase those who matter don\'t mind and those who mind don\'t matter

  9. #9
    AO übergeek phishphreek's Avatar
    Join Date
    Jan 2002
    Posts
    4,324
    check out http://www.linuxquestions.org/questi...002/08/2/27366

    Excalibur has some really good advise on how to troubleshoot/fix your problem. (no need to repeat it here)

    make sure you have the right module(s) loaded.
    Quitmzilla is a firefox extension that gives you stats on how long you have quit smoking, how much money you\'ve saved, how much you haven\'t smoked and recent milestones. Very helpful for people who quit smoking and used to smoke at their computers... Helps out with the urges.

  10. #10
    Senior Member
    Join Date
    Nov 2001
    Posts
    120
    Did ya try the XMMS patch for RedHat9. Also try changing the output plugin to OSS.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 Security News

     Patches

       Security Trends

         How-To

           Buying Guides