What am I doing wrong?
Results 1 to 7 of 7

Thread: What am I doing wrong?

  1. #1
    Elite Hacker
    Join Date
    Mar 2003
    Posts
    1,407

    Question What am I doing wrong?

    I am trying to get it to where you need a password to access users shares, and I also want it to go by username. I followed some directions on a site. First I disabled simple file sharing found under tools>folder options>view in my computer. Then I set a password for the guest account by going to computer management>users>Guest and right click and do set password. This makes it to where the users can access your files with a guest account but it requires the password you set for the guest account. This wasn't good enough for me. I want to be able to specify a user name when I access shares, so here is what I tried. in the group policy editor(type gpedit.msc at the run prompt) I went to Computer config>win settings>sec settings>local pol>user rights ass. and set the first file in there(access to this computer from the network) to allow what it had already plus another user. In properties I clicked on add user or group and added a user from my computer. Let's say the user was foobar and the computer was COMP, then what I added would say COMP\foobar. I also set it to this same user when I set a folder to be shared. I did this by going under sharing and security in the right click menu, then the sharing tab, and clicked shared this folder. Then I went under permissions and set it to let the same user access that folder. So now I go over to another winXP pro machine and type: net use x: \\192.168.0.110\Docs
    Then it gives me a prompt for a username and I type foobar, next is the password prompt where I type the password assigned to foobar on the computer sharing the folder. Every time I get an error that I may have used a bad username or password. I also tried COMP\foobar for the user, and also tried the guest user password, and the admin password no combo works. I would really like to be able to specify a username. The best I can get so far is if I specify for everyone to be able to access the folder both in gpedit and the folder properties. This setting makes it to where no username is required, but the Guest password is required. I know you can have user access to shares so what I would like you all to show me is how to get it setup with user access to shares. Can you please do this?
    Thank you for any replies and suggestions.

    edit
    Another interesting thing is that I also have a win98se machine with the same network logon as the winXP pros admin name. If I type: net use x: \\192.168.0.110\C$
    from the win98 comp and give the right admin password it gives me access to that share on my XPpro machine. But if I do this from another XPpro machine: net use z: \\192.168.0.110\C$ /user:admin
    where admin is the same as the admin username on the other XPpro box, and type in the correct password, I get network path not found, or bad password or some other error. Why does this happen? Shouldn't both be using the same username and password?

  2. #2
    Senior Member Wazz's Avatar
    Join Date
    Apr 2003
    Posts
    288
    Hmmmm, try to go into Administrative Tools>Computer Management>Shares and from here set the Share Permissions and Security Permissions for the User/Pass. This is how I set my shares and it works fine. Also, make sure that you have File and Printer Sharing checked on both machines' Local Area Connection...Hope this helps.

    "File and Printer Sharing for Microsoft Networks" checked off that is......
    "It is a shame that stupidity is not painful" - Anton LaVey

  3. #3
    Elite Hacker
    Join Date
    Mar 2003
    Posts
    1,407
    Do you mean uncheck file and printer sharing because I tried it and now I don't even get a password prompt. The thing in computer management is the same as the one I used when I right click the folder I want to share and go to sharing and security and permissions. Thanks for the reply, I'll keep fooling around with it and report back.

    edit
    I just did an experiment. I went to the XP pro machine and made a limited user account which was the same name as the admin account on the sharing computer. Then I ran the net use command and it asked me for a user name and I left it blank. Then it asked for a password, and I entered the admin password for the sharing computer and it worked. This still doesn't solve my problem. I should just be able to specify the username as the admin on the sharing comp and not have to make a separate user account.

    I just ran the net use command from another account that does not have the admin name to test something. When it prompted me for the username I entered the admin user then when I was prompted for a password I entered the admin password. The error it gave me was something about that user not being allowed that type of logon on this computer(i think meaning the computer I was trying to connect from). I think it may be a client side error. I'm going to change some settings and see what I come up with. Anyone have any ideas?

    I'm thinking this can't be done except in a domain. I have tried some more configs without luck. I know that at my school I am able to access a share by typing: net use z: \\server\share /user: username
    and then giving the password when prompted, but this server runs Solaris. I guess I will just have to go with having the guest account used with a password. That should be secure enough with a secure password. Thanks for the help.


    edit2
    I have done lots of probing now on my network. I just found out that someone can only access the C$, ADMIN$ and all those others $ things if you have simple file sharing turned off. I think my win98 machine is the best because all i have to do is set it to do a network logon and I can be any user I want on the network. If I want access to the C$ share on a computer with the admin name foobar I just log on to my win98 machine with username foobar, drop into the command prompt and do a little net use command, give the password and I'm in. Kindof neat and a good learning experience. Still haven't figured out the username network logon though. I probably never will. Peace


    edit3
    Well, here is what I've got. If you rename the guest account the user will have to put in the new name and password. Now if you could have multiple guest accounts then I guess you could have multiple users. [edit] just tried it and it didn't work. You can only use the built in guest account and rename it for more security. Hope this post is a good resource for other users of the site. [/edit]

  4. #4
    Senior Member OverdueSpy's Avatar
    Join Date
    Nov 2002
    Posts
    556
    Sounds like this is an authentication issue. "A user account defines the actions a user can perform in Windows. On a stand-alone computer or a computer that is a member of a workgroup, a user account establishes the privileges assigned to each user. On a computer that is part of a network domain, a user must be a member of at least one group. The permissions and rights granted to a group are assigned to its members."

    So create a domain or workgroup environment and you should be able to share the files with the security settings you desire.
    The mentally handicaped are persecuted in this great country, and I say rightfully so! These people are NUTS!!!!

  5. #5
    AO's MMA Fanatic! Computernerd22's Avatar
    Join Date
    Mar 2003
    Location
    Miami, FL
    Posts
    795
    Does your system allow anonymous logon? If not sure use the following

    C:\>net use \\ipaddress\ipc$ /user: dont know your real IP address go to www.whatismyip.com

    If you do not want your system allowing anonymous access: Go to start, run, type in: regedit which opens the registry editor

    Then go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA registry key and add the Restrict Anonymous registry value.

    Set the value of REG_WORD to 1

    Hope this helps User

  6. #6
    Elite Hacker
    Join Date
    Mar 2003
    Posts
    1,407
    In 2000 go to your control panel, and click on USERS AND PASSWORDS and add your users there. On XP I imagine its in the same place, but I dont have XP so I am unsure.

    On each machine you need to have:
    Laura
    Cathy
    Robert
    Guest ( which you should assign a password to)
    Rob Mike
    David
    Administrator ( I would rename this to something else)

    All the passwords need to be the same, and all these users need to be on each machine if all users need to get to the share, or you could selectively put certain users on certain machines and not on others, but this would allow everyone to share every share.
    full discussion here: http://www.duxcw.com/dcforum/DCForumID2/1946.html
    I think that answers my question. It seems as though to have user access enabled you must have the same users on both machines. That goes with what I experienced in my experiments. I think the only way to do what I want is to be a member of a domain. Thanks for the replies.

    p.s. OverdueSpy, I am part of a workgroup.

  7. #7
    Senior Member Maestr0's Avatar
    Join Date
    May 2003
    Posts
    604
    If your machine is not a member of a domain then any attempt to access the machine will result in the machine trying to authenticate against its own SAM. This means when you are prompted for a user password its looking to match it to a local account. If for instance you have 2 XP machines with an identical Admin name and Pass and your sharing is enabled you will be able to roam between the 2 at wil,l because the credentials will match the local admin account. Win98 does not support more advanced Net use features like allowing you to specify domain and user name it tries to use the logged in user and will prompt for PW. Since you are not in a domain I think using the computer name may be causing some of your problems because your probably do not have a WINS server running to resolve netbios names. Also attempting to log in as COMP\foobar is specifying that foobar is a member of the COMP domain which obviously isnt what we want. All you need is to create an account for file sharing on both machines and give that user permissions on the folders you wish to share. Then when you would like to be able to share you must first authenticate to that machine. I usually use the Start>Run> then \\COMPNAME this will try to use your credentials(who you are logged in as) first and if rejected will prompt for username and password. Once you enter the share account and its password the remote machine and its shares will become accessible to you with the share accounts credentials.

    -Maestr0
    \"If computers are to become smart enough to design their own successors, initiating a process that will lead to God-like omniscience after a number of ever swifter passages from one generation of computers to the next, someone is going to have to write the software that gets the process going, and humans have given absolutely no evidence of being able to write such software.\" -Jaron Lanier

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •