Not sure its really a 'security' issue - more a general fix for an MS problem.
(Likewise wasn't sure it was worthy of the tut section either)

For awhile I've had a problem that when performing certain installs or updates to a WinME system upon restart I would get an error, sometimes many dozen errors, stating:

Cannot upgrade file %1 from %2
%1 %2

While I know the best fix for this problem would be to install a real OS - as ME has to be the worst of the MS line of OS's, this isn't always an option. (Esp if working on someone elses home system). Also, I've heard referance to some people having this problem on XP also...

I spent a bunch of time, searching and re-searching the net and MS's website for a fix for this problem - and about the only thing I ever found was referance to removing some wininit file that doesn't even exist (at least not on any ME install I've seen).

Well I finally figured out what causes this problem and the simple thing needed to fix it.
"System Restore".

By this I don't mean you need to run a restore, or create a restore point. What I mean is that this error is caused by 'disabling' system restore - as many people do... So to fix it you need to re-enable system restore before installing/updating.

Here's a link to a good site that shows how to disable/enable system restore on either ME or XP.

I have found that on some ME systems this method of enabling doesn't always work, ergo you'll follow the steps, restart your system, and then if you check again it is still disabled. When this happens what I've found that seems to work to get around it is to do the following:
- First try to enable it the way described
- After restart check if the check-box is now checked or not
- If it still disabled then continue
- Open up 'system information'
- From the sys-info 'tools' menu open 'system restore'
- Choose to manually create a restore point
- The system will say it can't because its disabled, accept all the pop-up messages
- Restart the system again

This has worked, so far, for me on every system I've tried it. Once system restore is enabled run the installation/update and restart as regularly done, and you should no longer get the error messages preventing the change...

Hope this helps,