Disable port 25 TCP smtp
Results 1 to 6 of 6

Thread: Disable port 25 TCP smtp

  1. #1
    Banned
    Join Date
    Nov 2003
    Posts
    1,161

    Disable port 25 TCP smtp

    25 TCP smtp
    Simple Mail Transfer Protocol

    How do I get rid of this service? Its the only thing showing up in a Nmap localhost scan

  2. #2
    Senior Member st1mpy's Avatar
    Join Date
    Jun 2003
    Posts
    111
    what os and are you runing a mail server or something if not instal firewall and just set a rule for that port simple


    trying to help sorry if am wrong
    Un Seen But Well Heard Of

  3. #3
    Senior Member
    Join Date
    Sep 2003
    Posts
    500
    What distro are you running. In Mandrake just go to Mandrake Control Center ( or mcc in a terminal as root ) and disable it in the service menu. If I remeber correctly you were using mandrake and libranet.

    Otherwise you can type "/etc/rc.d/init.d/sendmail stop" and that should stop it manually each time.

    Otherwise again go to /etc/xinetd.conf or /etc/inetd.conf and comment out the process there. The service should be sendmail.
    You shall no longer take things at second or third hand,
    nor look through the eyes of the dead...You shall listen to all
    sides and filter them for your self.
    -Walt Whitman-

  4. #4
    Just Another Geek
    Join Date
    Jul 2002
    Location
    Rotterdam, Netherlands
    Posts
    3,403
    If you're running FreeBSD add sendmail_enable="NO" to your rc.conf. This will leave sendmail running so periodic can send emails to root but sendmail will not accept email from the outside anymore. If you really don't want to run sendmail you can use sendmail_enable="NONE".
    Oliver's Law:
    Experience is something you don't get until just after you need it.

  5. #5
    Elite Hacker
    Join Date
    Mar 2003
    Posts
    1,407
    I have the same thing on my RH9 box. When I scan localhost I see sendmail, but when I scan the actual IP it is not there. I have tried to connect to it from another PC and you can't. But it is still probably a good idea to disable it. Just go with the stuff everyone else said for that. I just wanted to say that it is probably not excessible from a remote PC, unless they are actually connected to your PC, such as through telnet. Did you try a scan on the actual IP also?

  6. #6
    Banned
    Join Date
    Nov 2003
    Posts
    1,161
    Guys Im sorry I didnt reveal my OS version. Im using Libranet 2.7

    By Landsing Banda
    If I remeber correctly you were using mandrake and libranet.
    Good memory I am using libranet and SuSE

    thnx guys


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •