RedHat 9 Problem
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: RedHat 9 Problem

  1. #1
    Member
    Join Date
    Sep 2003
    Posts
    76

    RedHat 9 Problem

    Hello there everybody, I was just talking with a buddy I gave a copy of RH 9 and he said that for some reason after everything is installed and he runs it for the first time his monitor shuts down and wont stay on any way. We tried installing red hat 8 and everything went great. Anyways if anyone out ther has any ideas as to why this is happening, I would appreciate the help. Thanx ins advance
    PD: my friends video card is a nvidia gforceFX 5200
    I Speak in frequencies even dogs have trouble hearing


  2. #2
    Senior Member
    Join Date
    Aug 2003
    Posts
    1,019
    I've been having the same problem with mandrake and debian also. All I have been able to figure out is that the version of Xfree86 that came with those distros just didn't like to play nice with nvida based cards.

    Oddly enough, when I installed knoppix-std to my hard drive (which is debian based), it works perfectly. I don't know enough how to correct the original problem I was having, and I have a working version now, so I haven't messed with it much....though at some point I would still like to get mandrake working.

  3. #3
    Senior Member
    Join Date
    Feb 2003
    Location
    Memphis, TN
    Posts
    3,747
    Just a guess here

    You might have to go to nvidias site and download the drivers for the FX 5200, and put them on a disc. Start the computer then put the disk in, but when you get to the grub boot loader press e to edit the kernel. Scroll down and select the kernel and press e I think. It should tell you what key you need to press to edit the kernel. you will then be able to add a line on to the end of the kernel. add this. "runlevel 4" without the "".

    After you do that, you want to boot using that kernel. That will take you into a text based login. You then want to go into the floppy disk, or CD whatever you have it on I belive the command for this would me something like cd /media/floppy or cd /media/cdrom 1 just when you enter the media directory type ls to show the available directories

    The nvidia driver file should be something like NVIDIA-0.9.42.sh.run or something similiar to that. just type in sh Filename. This should install the driver for you.

    Now I just did this the other day with my RH 9 system, but I may have forgotten something. maybe that will solve it for you.
    =

  4. #4
    Senior Member gore's Avatar
    Join Date
    Oct 2002
    Location
    Michigan
    Posts
    7,177

    Re: RedHat 9 Problem

    Originally posted here by Q-bel
    Hello there everybody, I was just talking with a buddy I gave a copy of RH 9 and he said that for some reason after everything is installed and he runs it for the first time his monitor shuts down and wont stay on any way. We tried installing red hat 8 and everything went great. Anyways if anyone out ther has any ideas as to why this is happening, I would appreciate the help. Thanx ins advance
    PD: my friends video card is a nvidia gforceFX 5200
    I have the exact video card in this box. I think what your problem is, is that you set up X with to high of a setting. Some monitors have a built in kill switch so to speak. If you danger them they shut off.

    I'v had Red Hat 9, Slackware 9, 9.1, Mandrake 9.1, SuSE 8.2, and Net BSD on here without a problem. I'm almost sure it is your display settings.

    Reinstall Linux, and when you come to setting up X, set it with safe settings. Find the manual for the monitor your friend has, and check out how much it can take and set it up like that. The vertical and horizontal refresh rate can damage your monitor if you set it too high.

    So use the Manual and set it with safe settings. That should work, but if it does not, please reply again.

  5. #5

    Re: RedHat 9 Problem

    Originally posted here by Q-bel
    Hello there everybody, I was just talking with a buddy I gave a copy of RH 9 and he said that for some reason after everything is installed and he runs it for the first time his monitor shuts down and wont stay on any way. We tried installing red hat 8 and everything went great. Anyways if anyone out ther has any ideas as to why this is happening, I would appreciate the help. Thanx ins advance
    PD: my friends video card is a nvidia gforceFX 5200
    Well here is the answer, turn power management of in the bios = STEP 1

    Then choose a screen saver so that it is not just blanking the screen out.. this happens when logged in as root most of the time depending on which GUI your running... which by the way which GUI did u choose or are you running Xw.

    Then set the screen saver so that it kicks in after 99999 seconds... this will stop the machine from blanking out the screen...



    Unless The problem is the reverse... This might be so as well

    If you can't seem to un blank the screen enable power management in the bios and enable a hot key to wake the monitor up... and then enable the screen saver and set it to 9999 etc.

    If no screen saver is chosen then when it blanks the screen sometimes if power management is disabled there is no way to wake up the monitor... depends on what irq's the system monitors or if the bios is told to watch any of them... i.e. such as wake on LAN etc... you can tell the bios what irq's to watch and when you enable irq for VGA make a note... go into the bios and make sure it is in the monitor list.

    In this case you want to make sure in the bios you enable irq for VGA... so that you can add it to you bios's monitoring list.

    Thats how I did it with a FX5600

    PEACE

  6. #6
    Senior Member gore's Avatar
    Join Date
    Oct 2002
    Location
    Michigan
    Posts
    7,177

    Re: Re: RedHat 9 Problem

    Originally posted here by TheGh0st
    Well here is the answer, turn power management of in the bios = STEP 1

    Then choose a screen saver so that it is not just blanking the screen out.. this happens when logged in as root most of the time depending on which GUI your running... which by the way which GUI did u choose or are you running Xw.

    Then set the screen saver so that it kicks in after 99999 seconds... this will stop the machine from blanking out the screen...



    Unless The problem is the reverse... This might be so as well

    If you can't seem to un blank the screen enable power management in the bios and enable a hot key to wake the monitor up... and then enable the screen saver and set it to 9999 etc.

    If no screen saver is chosen then when it blanks the screen sometimes if power management is disabled there is no way to wake up the monitor... depends on what irq's the system monitors or if the bios is told to watch any of them... i.e. such as wake on LAN etc... you can tell the bios what irq's to watch and when you enable irq for VGA make a note... go into the bios and make sure it is in the monitor list.

    In this case you want to make sure in the bios you enable irq for VGA... so that you can add it to you bios's monitoring list.

    PEACE
    Um, he said THE MONITOR TURNS OFF AND WON'T TURN ON. It's his X configuration. when you install Redhat there isn't even a screen saver set by default, but that doesn't matter anyway. The monitor is shutting down just like mine did one of the first times I installed Linux.

    Fixing the X configuration solves this. Which is why I said he should get the manual for the monitor and see what settings are safe.

    Which reminds me; If you can't find the manual for the monitor, or for some reason don't have it, look it up online and find the settings it can handle.

  7. #7

    Re: Re: Re: RedHat 9 Problem

    Originally posted here by gore
    Um, he said THE MONITOR TURNS OFF AND WON'T TURN ON. It's his X configuration. when you install Redhat there isn't even a screen saver set by default.
    Well thats what appeared to be happening with mine and I would have to turn the machine back off and then on again to get it to work. I called redhat and thats what they told me to do and I ended up with power management disabled and still set it to monitor the irq and now it doesn't turn off.

    Several ppl told me all I had to do was enable the screen saver and the command to shut the screen down would never arise...

    I know there is no screen saver by default thats why the screen blanks, the bios uses several methods of blanking the screen. I just did what the guy told me to do and my box stays lit.

    I have screen savers that freeze the machine sometimes but other than that my screen stays on and doesn't turn itself off.

  8. #8

    Re: Re: Re: RedHat 9 Problem

    Originally posted here by gore
    Um, he said THE MONITOR TURNS OFF AND WON'T TURN ON. It's his X configuration. when you install Redhat there isn't even a screen saver set by default, but that doesn't matter anyway. The monitor is shutting down just like mine did one of the first times I installed Linux.

    Fixing the X configuration solves this. Which is why I said he should get the manual for the monitor and see what settings are safe.

    Which reminds me; If you can't find the manual for the monitor, or for some reason don't have it, look it up online and find the settings it can handle.
    Ahh yes good point I did have that happen once when I hooked a test monitor up that was not able to do 1280x1024...

  9. #9
    Senior Member gore's Avatar
    Join Date
    Oct 2002
    Location
    Michigan
    Posts
    7,177

    Re: Re: Re: Re: RedHat 9 Problem

    Originally posted here by TheGh0st
    I have screen savers that freeze the machine sometimes but other than that my screen stays on and doesn't turn itself off.
    I'v noticed with Redhat that if you use a very graphical screen saver, like the end game chess screen saver for example, that it seems to skip, even after upgrading Nvidia drivers. Never had this problem on any other distro though. I think it's just because redhat sucks.

    EDIT:

    For your post below:

    It seems to be working fine, I just gave you greenies and it worked out fine.

    Also, if you have an extra $80, I'd recommend buying SuSE 8.2 or 9.0 Professional. It's ALOT better than redhat. I'v turned quite a few redhat users on to SuSE and also some Linux newbies onto it.

    http://www.suse.com

  10. #10

    gore

    You know what I hate...



    Sorry, the AntiPoints system has been disabled. This means someone is messing with the point system while users are posting lol I went to give ya some pos but got that stupid message.. I will try and remember to check and see when who ever is monkeyn around in there is finished...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •