Ok,
Here is the deal. I am about to go insane, i have been working on this for about 4 days straight now. I think this is more than enough information to explain my whole situation. Please read the Error messages very closely to understant the Problem. Thanks alot.

My setup:
We have a T4 line comming into our house and going to a Linksys Router, which is fed to a switch then distributed over all the rooms in the house. Everyone elses works fine as far as i know. I am running a RealTek RTL8139 Family Fast ethernet NIC on my computer. But the weird thing is that i now it is RTL8139/810X and im not sure if it used to be or not. I dont think that it was. But anytime i try to reinstall the driver that is what it calls it. I am running Windows XP professional.

So up until about 4 days ago my computer would let me get on the internet just fine. I went to sleep and i got up and i could not get on the internet so i did the basic IPCONFIG Release/Renew. However i noticed that i couldn't release my IP address because it was autoconfigured to be a 169.xxx.xxx.xxx, when i should be pulling a 192.168.x.xxx as i used to be able to do. I have tried everything (uninstalled the drivers and reinstalled them, deleted the keys in the registry from previous installs of the drivers so that it wasnt reading from an old driver, I have tried assigning a static IP/Subnet Mask/Default Gateway/DNS, I have even tried spoofing my MAC address, I tried plugging it into another rooms line to see if it was my switch) and now today i started stumbling across some things beyond my knowledge. I was looking through the windows manager and i came across a large amount of system errors. I have looked them all up and learned about them but i have not found a way to actually fix the problem. Here are some of the errors that i pulled out.

Event Type: Error
Event Source: MRxSmb
Event Category: None
Event ID: 8003
Date: 12/3/2003
Time: 11:00:15 PM
User: N/A
Computer: HAUK
Description:
The master browser has received a server announcement from the computer PHI-1IG6TSWJNFO that believes that it is the master browser for the domain on transport NetBT_Tcpip_{F4208202-221. The master browser is stopping or an election is being forced.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 00 00 00 00 03 00 4e 00 ......N.
0008: 00 00 00 00 43 1f 00 c0 ....C..
0010: 00 00 00 00 00 00 00 00 ........
0018: 00 00 00 00 00 00 00 00 ........
0020: 00 00 00 00 00 00 00 00 ........

*****
Event Type: Error
Event Source: Dhcp
Event Category: None
Event ID: 1000
Date: 12/7/2003
Time: 4:28:26 PM
User: N/A
Computer: HAUK
Description:
Your computer has lost the lease to its IP address 192.160.1.103 on the Network Card with network address 0090F50D2052.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

*****
Event Type: Error
Event Source: Dhcp
Event Category: None
Event ID: 1002
Date: 12/7/2003
Time: 11:57:57 PM
User: N/A
Computer: HAUK
Description:
The IP address lease 192.160.1.122 for the Network Card with network address 0090F50D2052 has been denied by the DHCP server 192.160.1.1 (The DHCP Server sent a DHCPNACK message).

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

*****
Event Type: Warning
Event Source: Dhcp
Event Category: None
Event ID: 1003
Date: 12/8/2003
Time: 2:54:30 PM
User: N/A
Computer: HAUK
Description:
Your computer was not able to renew its address from the network (from the DHCP Server) for the Network Card with network address 0090F50D2052. The following error occurred:
The operation was canceled by the user. . Your computer will continue to try and obtain an address on its own from the network address (DHCP) server.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: c7 04 00 00 ...

*****
Event Type: Warning
Event Source: Dhcp
Event Category: None
Event ID: 1009
Date: 12/8/2003
Time: 2:54:30 PM
User: N/A
Computer: HAUK
Description:
A network error occurred when trying to send a message. The error code is: The requested address is not valid in its context. .

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 27 00 00 A'..

*****
Event Type: Warning
Event Source: Dhcp
Event Category: None
Event ID: 1006
Date: 12/8/2003
Time: 3:56:54 PM
User: N/A
Computer: HAUK
Description:
Your computer was unable to automatically configure the IP parameters for the Network Card with the network address 0090F50D2052. The following error occurred during configuration: The DHCP client has obtained an IP address that is already in use on the network. The local interface will be disabled until the DHCP client can obtain a new address. .

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 04 10 00 00 ....

*****
Event Type: Error
Event Source: NetBT
Event Category: None
Event ID: 4311
Date: 12/10/2003
Time: 2:19:57 AM
User: N/A
Computer: HAUK
Description:
Initialization failed because the driver device could not be created.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 00 00 00 00 01 00 58 00 ......X.
0008: 00 00 00 00 d7 10 00 c0 ......
0010: 11 01 00 00 01 00 00 c0 .......
0018: 00 00 00 00 00 00 00 00 ........
0020: 00 00 00 00 00 00 00 00 ........

*****
Event Type: Error
Event Source: ACPI
Event Category: None
Event ID: 5
Date: 12/10/2003
Time: 11:20:57 AM
User: N/A
Computer: HAUK
Description:
AMLI: ACPI BIOS is attempting to write to an illegal IO port address (0x70), which lies in the 0x70 - 0x71 protected address range. This could lead to system instability. Please contact your system vendor for technical assistance.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 00 00 00 00 04 00 52 00 ......R.
0008: 00 00 00 00 05 00 05 c0 .......
0010: 00 00 00 00 00 00 00 00 ........
0018: 00 00 00 00 00 00 00 00 ........
0020: 00 00 00 00 00 00 00 00 ........

*****
Event Type: Error
Event Source: ACPI
Event Category: None
Event ID: 4
Date: 12/10/2003
Time: 11:20:57 AM
User: N/A
Computer: HAUK
Description:
AMLI: ACPI BIOS is attempting to read from an illegal IO port address (0x71), which lies in the 0x70 - 0x71 protected address range. This could lead to system instability. Please contact your system vendor for technical assistance.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 00 00 00 00 04 00 52 00 ......R.
0008: 00 00 00 00 04 00 05 c0 .......
0010: 00 00 00 00 00 00 00 00 ........
0018: 00 00 00 00 00 00 00 00 ........
0020: 00 00 00 00 00 00 00 00 ........

*****
Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7026
Date: 12/10/2003
Time: 11:23:24 AM
User: N/A
Computer: HAUK
Description:
The following boot-start or system-start driver(s) failed to load:
TPkd

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

*****
Event Type: Warning
Event Source: Dhcp
Event Category: None
Event ID: 1007
Date: 12/10/2003
Time: 7:42:39 PM
User: N/A
Computer: HAUK
Description:
Your computer has automatically configured the IP address for the Network Card with network address 0090F50D2052. The IP address being used is 169.254.196.179.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 00 00 00 00 ....

*****
These are the errors that i started researching and i found some things about it but no actual way to fix it. I found a couple of people talking about it and they said that i need to edit like one or mulitple of these (dhcp.conf ; dhcpd.conf ; etc/network/interfaces ; etc/dhcp3/dhclient.conf). So from there i have no idea what to do. I am gettin really pissed off with this b/c it would be 100x easier to get on the internet and just look for stuff on there but i cant. I have to go back and forth between computers that have the internet and mine. I know it is not anything that is obvious. i have messed around with all the settings and i cant pull a 192.xxx IP for the life of me. Someone please help me, i am going insane!!!

-Ryan