mp3's on redhat
Results 1 to 10 of 10

Thread: mp3's on redhat

  1. #1
    Blast From the Past
    Join Date
    Jan 2003
    Posts
    729

    mp3's on redhat

    i downloaded winamp for linux but it doenst play mp3's
    how can i get linux to play them cause thats manily all i hav when it comes to my collection
    work it harder, make it better, do it faster, makes us stronger

  2. #2
    Banned
    Join Date
    Sep 2002
    Posts
    222
    Well, Redhat decided not to ship with the packages xmms-mp3. You need to download and install that fileset, and you should be all right.

    Also, check this thread out: http://www.antionline.com/showthread...hreadid=246434

  3. #3
    Blast From the Past
    Join Date
    Jan 2003
    Posts
    729
    i downloaded xmms 1.2.8 and it ses it needs 1.2.7 to work
    so i download that and it ses i have glib 1.2.2 and glbi1.2.10 installed and that i need to get rid of one but i cant figure out how
    how do i get rid of glib 1.2.2?
    work it harder, make it better, do it faster, makes us stronger

  4. #4
    Senior Member
    Join Date
    Aug 2003
    Posts
    1,019
    Here, a special little present just for you http://www.google.com/linux This is where I went when I needed to figure out why I couldn't play mp3.

    But seriously, did a manual come with your install of redhat? If not, try these:
    https://rhn.redhat.com/index.pxt
    http://www.redhat.com/docs/
    https://www.redhat.com/apps/support/

    Good luck.

  5. #5
    Blast From the Past
    Join Date
    Jan 2003
    Posts
    729
    checking for GLIB - version >= 1.2.2...
    *** 'glib-config --version' returned 1.2.2, but GLIB (1.2.10)
    *** was found! If glib-config was correct, then it is best
    *** to remove the old version of GLIB. You may also be able to fix the error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If glib-config was wrong, set the environment variable GLIB_CONFIG
    *** to point to the correct copy of glib-config, and remove the file config.cache
    *** before re-running configure
    no
    configure: error: *** GLIB >= 1.2.2 not installed - please install first ***


    thats what i get when i try to install xmms-1.2.7 which is required by xmms 1.2.8 or thats what my rpm manager ses
    now from i make of this i need to uninstall glib-1.2.2 and i cant find anyting on google and i searched these items
    uninstall glib/remove glib/uninstall glib-1.2.2/remove glib-1.2.2 and i cant find anyting
    i was in the ad/remove packages and i found it but it wont let me uninstall it either and i cant locate the manual
    i typed this man glib/man glib-1.2.2 and i got nothing
    i caused this problem by not knowing i had version 1.2.2 and i installed 1.2.10 and now there is a clash
    the output also tells me to edit /etc/ld.so.conf. but that file doesnt list anything about glib and i have no idea where my LD_LIBRARY_PATH or GLIB_CONFIG files are
    all i want to do is listen to mp3's while doing what ever i do y does this have to be so dificult
    am i doing something wrong or not doing something
    and remember im for the most part a noob at linux thats y ive had all these questions im currently reading running linux by o'reilly books and im about 25% through
    everything else i know is through trial and error and trial and error is the reason ive messed up my filesystem 3 times
    work it harder, make it better, do it faster, makes us stronger

  6. #6
    Senior Member
    Join Date
    Aug 2003
    Posts
    1,019
    Check your man rpm pages..it tells you how to uninstall, and all the relevent switches. I have never removed packages, so I'm probably not much help. I did stay at a Holiday Inn Express last night though.

    Good Luck

  7. #7
    Blast From the Past
    Join Date
    Jan 2003
    Posts
    729
    [root@localhost root]# rpm -e glib-devel
    error: Failed dependencies:
    glib-devel is needed by (installed) gtk+-devel-1.2.10-25
    glib-devel is needed by (installed) ORBit-devel-0.5.17-7
    glib-devel is needed by (installed) GConf-devel-1.0.9-10


    thats what i get when i do it the command line way
    im reading the rpm manuel now and im going to try to find a glib-1.2.10 rpm and upgrade it and this is what i get


    [root@localhost root]# rpm -F /root/glib.rpm
    warning: only V3 signatures can be verified, skipping V4 signature
    [root@localhost root]# rpm -F --allfiles /root/glib.rpm
    warning: only V3 signatures can be verified, skipping V4 signature

    what the hell are V signatures
    work it harder, make it better, do it faster, makes us stronger

  8. #8
    Senior Member
    Join Date
    Aug 2003
    Posts
    1,019
    Err... I dunno.. http://list.waikato.ac.nz/pipermail/...ay/013240.html

    Other than that, I have no idea what you have going on...I installed the glib, and then xmms, and it worked.

    Sorry...it's over my head.

    EDIT: What desktop are you using, btw? I guess when I did remove things I didn't want, I used Nautilus..it's probably not the right way to remove stuff, but it was easy.

  9. #9
    Blast From the Past
    Join Date
    Jan 2003
    Posts
    729
    im using gnome and natuilus redhat9
    work it harder, make it better, do it faster, makes us stronger

  10. #10
    Blast From the Past
    Join Date
    Jan 2003
    Posts
    729
    SECUESS!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    i was about to give up then i found out that i had a bad block on my hdd so i changed out for a different one and started anew and it works!!!
    mp3's wont work in winamp but xmms is just fine
    work it harder, make it better, do it faster, makes us stronger

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •