NIS on RedHat
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: NIS on RedHat

  1. #1
    Senior Member
    Join Date
    Jun 2003
    Posts
    142

    Linux questions.....

    Hello...everyone, I have some problems here with my Linux Box. and I was wondering if someone could answer these questions.
    I have Red Hat 7.2 on my machine.. I tried to configure NIS server on my machine but somehow, NIS cannot be configured. The problem it caused is that on booting the machine it starts listening to an NIS domain(which is not obviously there)..it takes a few minutes in this process. Now when it fails to listen to NIS...it switiches to runlevel 3 instead of booting into runlevel 5. I stopped 'YPBIND' and 'YPSERV' daemons, but every time you boot the system it starts listening to NIS , which, eventually fails(and it takes lot s of time to do so and delays bootig process). Now I want to stop these services so that these daemons does not invoke during the booting
    process as well. Can anyone help me out with this? and please do let me know any Linux forums where I can post my "HOW-TO" questions...
    Thank you
    Ommy

  2. #2
    Senior Member
    Join Date
    Aug 2003
    Posts
    1,019
    First thing I would do is either delete this post and move it to the OS section of the forums, or if you can't figure out how to do that, ask MsMittens to do it for you. You're asking a question that deals more with operations issues.

    Try http://www.google.com/linux... not specific to your question, but it narrows your search results..

    Once you get to the aforementioned section of google, type in "forms" or "bulletin boards" or "tutorials"....

    Or do a search specific to your problem. Chances are that if you are having an issue with something, somebody else probably already did also, and had their question answered.. (kind of like here)

    EDIT: Also, check out the search feature of AO... resources for Linux have been discussed many times, and many links have been provided.

  3. #3
    Member
    Join Date
    Dec 2001
    Posts
    87
    Try "chkconfig ypserv off" without the quotes.

  4. #4
    Senior Member Info Tech Geek's Avatar
    Join Date
    Jan 2003
    Location
    Vernon, CT
    Posts
    828
    I found some great information on the Linux Documentation Project Website.

  5. #5
    Member
    Join Date
    May 2002
    Posts
    68
    Boot the run level 3, then try running /etc/pam.d/authconfig (not positive on the path, don't have linux running where iam) but when you get it running it'll have a blue screen wizard. Set it not authenticate off any servers, just linux shadow passwords. Then restart, see if it boots up ok. If that doesn't help, or you use pam.conf and don't have the above dir, then post more information about the problem.
    [gloworange]
    find /home/$newbie -name *? | www.google.com 2>/dev/null
    [/gloworange]

  6. #6
    Member
    Join Date
    Dec 2001
    Posts
    87
    /etc/pam.d/authconfig is just the pam permissions file for running the authconfig program. The actual program is /usr/bin/authconfig or /usr/bin/authconfig-gtk for the x version.

  7. #7
    Antionline Herpetologist
    Join Date
    Aug 2001
    Posts
    1,165
    Editing one of the rc files (rc.3?) and removing (commenting out) the lines that say yp*should do it.
    Try this:
    cd /etc/rc.d
    grep yp rc.*
    It'll tell you which file(s) has the commands.
    Just add a # at the beginning of those lines and reboot.

    Cheers,
    cgkanchi
    Buy the Snakes of India book, support research and education (sorry the website has been discontinued)
    My blog: http://biology000.blogspot.com

  8. #8
    Senior Member
    Join Date
    Aug 2003
    Posts
    1,019
    Ok, now for my question..

    Editing one of the rc files (rc.3?) and removing (commenting out) the lines that say yp*should do it.
    Try this:
    cd /etc/rc.d
    grep yp rc.*
    It'll tell you which file(s) has the commands.
    Just add a # at the beginning of those lines and reboot.
    Boot the run level 3, then try running /etc/pam.d/authconfig (not positive on the path, don't have linux running where iam) but when you get it running it'll have a blue screen wizard. Set it not authenticate off any servers, just linux shadow passwords.
    Being as how I am a linux newbie, I'm curious as to what your assesment of the problem is, and what (each of you) are trying to accomplish by doing the above? I am assuming that you have run into this type of problem before? Just trying to get some clarification...never know when I may need the information.

  9. #9
    Member
    Join Date
    Dec 2003
    Posts
    43
    People were telling you that your machine is attempting to authenticate using yp, because it is still in the authentication configuration. And, that even though you stopped a yp service, it may have come back after a reboot, unless you stopped it from starting.,

    Make sure the yp services do not start on boot( that was editing th rc files, and also, the easier way on redhat anyway "chkconfig ypserv off" as owensleftfoot said).

    Make sure that your machine does not try to use NIS for authentication( authconfig).

    You need to run authconfig as root, and unselect anything which mentions NIS, then run

    chkconfig --list

    and look through it to find all of the NIS related services which are scheduled to start in runlevel 5 or 3,

    and then run

    chkconfig <servicename> off

    for each of them, I think the following are the NIS services you will need to turn off

    chkconfig ypserv off
    chkconfig ypbind off <----------------- I think this one, along with autconfig change, solves problem.
    chkconfig yppasswd off

    You can also turn off portmap unless you are using nfs...

    chkconfig portmap off

  10. #10
    Member
    Join Date
    May 2002
    Posts
    68
    Originally posted here by owensleftfoot
    /etc/pam.d/authconfig is just the pam permissions file for running the authconfig program. The actual program is /usr/bin/authconfig or /usr/bin/authconfig-gtk for the x version.
    You are correct but I think i mention pam because I was picking up on his not being able to boot to X but still get to level3. Sometimes there are PAM issues specifically with run level5.
    [gloworange]
    find /home/$newbie -name *? | www.google.com 2>/dev/null
    [/gloworange]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •