Ethereal Packet sniffer problem
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Ethereal Packet sniffer problem

  1. #1
    Senior Member
    Join Date
    Jun 2003
    Posts
    772

    Ethereal Packet sniffer problem

    I succesfully installed WinPcap 3.0 as I can sniff traffic with Windump.
    But when I try to use Ethereal this error appears:

    ------------------------------------------------------------------------------
    The capture session could not be initiated (Error opening adapter: The System cannot find the file specified)
    Please check that you have the proper interface specified.

    Note that the driver Ethereal uses for packet capture on Windows doesn't support capturing on PPP/WAN interfaces in Windows NT/2000/XP/.NET server
    ------------------------------------------------------------------------------

    Well this shouldn't be a problem as I try to use it on Windows 98.
    And also it's not a PPP interface I'm trying to sniff.

    The adapter name is: SANTIS WLAN USB Adapter: FVNETusbASKEY (AR)(R)

    (It's an usb adapter for a WLan (Siemens Santis 50 wireless adsl router -> http://www.siemens.com/index.jsp?sdc...id=1669042413&)

    I find this strange as I succesfully can sniff traffic using Windump. (And of course the adapter is properly installed as I am connected to the wlan and I'm online so)
    Anyone know what the problem could be?
    The above sentences are produced by the propaganda and indoctrination of people manipulating my mind since 1987, hence, I cannot be held responsible for this post\'s content - me

    www.elhalf.com

  2. #2
    Senior Member Wazz's Avatar
    Join Date
    Apr 2003
    Posts
    288
    Did you go into the Ethereal options. "The System cannot find the file specified)
    Please check that you have the proper interface specified". It sounds like the wrong device may be selected in the settings.
    "It is a shame that stupidity is not painful" - Anton LaVey

  3. #3
    Senior Member
    Join Date
    Jun 2003
    Posts
    772
    Nope, it's the correct device, there's also PPP MAC but that interface isn't in use (doesn't exist either actually , probably from my dial-up modem)
    The above sentences are produced by the propaganda and indoctrination of people manipulating my mind since 1987, hence, I cannot be held responsible for this post\'s content - me

    www.elhalf.com

  4. #4
    Senior Member Wazz's Avatar
    Join Date
    Apr 2003
    Posts
    288
    Hmmmm, I would go here: http://ethereal.planetmirror.com/faq.html#q5.4 and see if you can narrow down the problem. And I also found a user with the same problem, this was the response: "Can anybody supply the correct ethereal command line in W2K that would
    > allow capture on the fast ethernet interface?

    tethereal -i \Device\Packet_{BD11F961-9620-4761-8EF6-6E1F1821D2CD}

    > I've tried different options using the ID within the {}

    The reason why Ethereal displays the string complete with
    "\Device\Packet_" and the "{" and "}" is that they are part of the name
    you have to supply in order to capture on the device. You can't just
    use the ID, you have to use the whole string".

    Good Luck ....Oh and WinPcap 3.01 is available and listed as an importanbt upgrade here: http://winpcap.polito.it/ Try that
    "It is a shame that stupidity is not painful" - Anton LaVey

  5. #5
    Senior Member
    Join Date
    Jun 2003
    Posts
    772
    Thanks, I can even capture traffic using tethereal but not using ethereal itself, /me finds that odd...
    The above sentences are produced by the propaganda and indoctrination of people manipulating my mind since 1987, hence, I cannot be held responsible for this post\'s content - me

    www.elhalf.com

  6. #6
    Senior Member Wazz's Avatar
    Join Date
    Apr 2003
    Posts
    288
    That is weird.....I'm gonna install it now and see if I have the same problem (got nothing to do for a little while .....I'm on my XP box though. Let me know if you figure it out and I'll see what happens on this end.
    "It is a shame that stupidity is not painful" - Anton LaVey

  7. #7
    I couldn't get Ethereal to work on my win98 laptop, then I read somewhere that it doesn't work in 9X, the same error opening adapter came up.

  8. #8
    Senior Member
    Join Date
    Jun 2003
    Posts
    772
    It works on win98 and I can sniff traffic on the first adapter, only: there is no traffic on that adapter as it is not in use.
    The above sentences are produced by the propaganda and indoctrination of people manipulating my mind since 1987, hence, I cannot be held responsible for this post\'s content - me

    www.elhalf.com

  9. #9
    Senior Member Wazz's Avatar
    Join Date
    Apr 2003
    Posts
    288
    You may have to bind it to your adapter as a protocol. I seem to remember when I first installed it a while back, it was listed in my Local Area Connection and I had to check it. Try going into your Win98 Network settings and looking for a way to bind it. I tried it on my XP box and it worked perfectly. I use Sniffer Pro now so I ditched Ethereal a while ago. Good Luck.
    "It is a shame that stupidity is not painful" - Anton LaVey

  10. #10
    Senior Member
    Join Date
    Jun 2003
    Posts
    772
    It is binded, when I installed it it automatically did that.
    I know what the problem is now, some guy from Ethereal told me, it's because the name of the adapter I want to use consists of multiple spaces and Ethereal seperates Description and name the wrong way then.

    Thanks anyway, for the effort
    The above sentences are produced by the propaganda and indoctrination of people manipulating my mind since 1987, hence, I cannot be held responsible for this post\'s content - me

    www.elhalf.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •