"view source" problem
Results 1 to 3 of 3

Thread: "view source" problem

  1. #1
    Junior Member
    Join Date
    Apr 2003

    Angry "view source" problem

    For a while now, whenever i try to view the source for a web site, it wont come up. It is the same with aol and ie and i have tried many web sites. tech support cant help me, and i dont know how the hell to fix this...any ideas???

  2. #2
    AntiOnline n00b
    Join Date
    Feb 2004
    There are number of reasons for the View Source to not work in IE
    • Temporary Files Full
    • Cookie Folder Location
    • Missing Notepad.exe
    • Incomplete Page Download
    • View Source Restriction
    • Change View Source Program

    Temporary Files Full
    Delete the Temporary Internet Files, otherwise known as the disk cache. The cache includes local copies of web pages and files, so the browser doesn't have to download them again.

    In the Tools menu, open Internet Options.... In the General tab, in the Temporary Internet files section, click on Delete Files.

    It seems "view source" is affected when the cache gets too large in size. Internet Explorer takes the source from the Temporary Internet Files folder to the folder specified by the TMP environment variable. Refer to Microsoft article 179829 for more information about this.

    Cookie Folder Location
    This issue can also occur if your Cookies folder is located on an NTFS partition and you do not have at least Change permissions for the Cookies folder. To resolve, make sure your account has sufficient permissions on the Cookies folder.

    Missing Notepad.exe
    Check whether the notepad.exe is in the windows directory.

    Incomplete Page Download
    If you press the ESC key before the page has completed loading then sometimes the "View Source" menu item may not be displayed

    View Source Restriction
    The View Source function may have been restricted by your Administrator or some one else. To resolve, see the "NoViewSource" registry value in Internet Explorer Restrictions.
    User Key=HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\NoViewSource
    Data Type: REG_DWORD (DWORD Value)
    Value Data: (0 = disable restriction, 1 = enable restriction

    Change View Source Program
    try changing it something else say you want to change it from Notepad.exe to wordpad.exe see if it works
    System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\
    View Source Editor\wordpad.exe]
    Value Name: (Default)
    Data Type: REG_SZ (String Value)
    Value Data: c:\windows\wordpad.exe

    For further information check out these articles at Microsoft

    • 179829

      Specify a valid path for the TMP environment variable
    • 203592

      Include the Change permission for the Cookies folder
    • 306907

      Delete Temporary Internet files
    • 154168

      Extract or expand the Notepad.exe file from your original Windows disks or CD-ROM to the Windows folder

    --Good Luck--

  3. #3
    Junior Member
    Join Date
    Apr 2003
    worked like a charm...thank you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts