Cannot access Fat32 partition from user account
Results 1 to 3 of 3

Thread: Cannot access Fat32 partition from user account

  1. #1
    Senior Member
    Join Date
    Oct 2003
    Posts
    234

    Cannot access Fat32 partition from user account

    I recently moved from RedHat to Debian and now have decided on Slackware. I think Slackware is great and it just might be my favorite distro, if I can configure the damn thing. Right now I'm having some problems accessing my windows drive from my user account. I've tried editing my fstab and changing permissions of the /dev file and the windows directory (where I told it to mount), but I can still not access it from my user account. If you need it, I can post my fstab or any other config files.

    Thanks, I'm a bit of a noob at this!

  2. #2
    Just a Virtualized Geek MrLinus's Avatar
    Join Date
    Sep 2001
    Location
    Redondo Beach, CA
    Posts
    7,324
    I used to run into the same problem. I had to su - to root and then copy the item, chown and/or chmod it and.. sigh. It was frustrating. Did a bit of searching around and lo' and behold, I wasn't the only one. Through the searches I discovered that the following in my fstab helped to ensure the user to access the Windows partition:

    /dev/hda2 /windows vfat user,umask=000 1 0
    (Obviously, for your installation, the hard drive reference and mount point may be different).

    Hope this helps.
    Goodbye, Mittens (1992-2008). My pillow will be cold without your purring beside my head
    Extra! Extra! Get your FREE copy of Insight Newsletter||MsMittens' HomePage

  3. #3
    Senior Member
    Join Date
    Oct 2003
    Posts
    234
    Thanks Ms. Mittens, exactly what I was looking for. I had seen those options but wan't sure what I needed to specify. Yeah, chmod, chown, and chgrp did not work for me either, always returned an error or didn't do anything. Hope this works!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •