Firewall/Samba Problems
Results 1 to 3 of 3

Thread: Firewall/Samba Problems

  1. #1
    Senior Member
    Join Date
    Nov 2003
    Posts
    247

    Firewall/Samba Problems

    I've been trying for a while to enable Samba on my Linux box, running SuSE 9.0. I've had the network set up without a problem, and I could see all the other boxes without a problem from ANY of my Windows computers. I could even see the Linux computer while browsing the network from a Windows box, but could not actually browse to it.

    The firewall was set up to allow traffic through on Port 139 (which should be the port for Samba). I continued to get warnings during the boot up that I still had to allow Samba through the firewall, on port 139.

    After tweaking the firewall a bit more, I got sick of it and disabled it, because all internet access was disabled. After doing this, I was suddenly able to browse the network, to and from the Linux box, as I should have been able to do before. Mounting shares from other computers was no longer a problem.

    The firewall that I was using was the standard firewall that comes with SuSE 9.0. Any advice on how to fix this problem, and sitll have my firewall in place? :oesn't trust the routers and built in firewalls any further than he can move them with his mind.::

    Thanks in advance, guys.
    www.ADigitalPimp.com
    There is a ghost in the machine, and he is my friend.

  2. #2
    AO übergeek phishphreek's Avatar
    Join Date
    Jan 2002
    Posts
    4,325
    SonofGalen: let me check my config,

    SMB TCP 445
    netbios ssn TCP 139
    netbios ssn UDP 139
    netbios ns UDP 137

    You can use just SMB without netbios too. Just allow TCP 445. (I believe.... I use both...)

    I'm using iptables with fwbuilder to build my policy.

    SMB over TCP vs. SMB over NBT

    The SMB (Server Message Block) protocol is used among other things for file sharing in Windows NT / 2000. In Windows NT it ran on top of NBT (NetBIOS over TCP/IP), which used the famous ports 137, 138 (UDP) and 139 (TCP). In Windows 2000, Microsoft added the possibility to run SMB directly over TCP/IP, without the extra layer of NBT. For this they use TCP port 445.
    http://ntsecurity.nu/papers/port445/

    Huh... thats weird. I don't have UDP 138 open and mine still works.
    Maybe all you need is TCP 445? I'll test it quicklike.

    Yup. I just tested it. Works fine with just TCP 445. That is all you should need to enable.

    However, if you disable netbios, it probably won't show up in network neighborhood.
    Or, whatever they are calling it these days. The network browser.
    Quitmzilla is a firefox extension that gives you stats on how long you have quit smoking, how much money you\'ve saved, how much you haven\'t smoked and recent milestones. Very helpful for people who quit smoking and used to smoke at their computers... Helps out with the urges.

  3. #3
    Senior Member
    Join Date
    Nov 2003
    Posts
    247
    Alright, as soon as I'm done copying these files over (used Samba to back-up) I'll try that and report back. Thanks. ;-)
    www.ADigitalPimp.com
    There is a ghost in the machine, and he is my friend.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •