getty not starting....whyyyyyyy?
Results 1 to 5 of 5

Thread: getty not starting....whyyyyyyy?

  1. #1
    Senior Member
    Join Date
    Dec 2003
    Posts
    121

    Question getty not starting....whyyyyyyy?

    Hi to all!!!!
    Ok here is the deal: i have installed with a friend a debian distro (woody) and everything went well (except for the xfree86-but the problem seemed to be with the usb mouse). Then we decided to compile the 2.4.26 and the 2.6.5 kernels as the current kernel was 2.4.18.We downloaded them,used a previous configuration for the 2.4.25 which worked perfectly on another computer and we changed only some unimportant things (p.e. i dont have ISDN so unmarked the things which referred to it). Then compiled with the 'debian' process (dpkg is really good!!!) and configured lilo..everything well till now...I have also to say that we updated all libraries and getty and some other progs.Then we booted the system crossing fingers...
    All daemons started correctly,all services ok and after cron starts it is time for getty to start and give me the tty0...tty6. But...getty would not give me the consoles! I ran on runlevel 1 everything else is ok even the X starts ok,i checked many times the configuration of the kernel (compiled again and again 5 times 2.4.26,6 times 2.6.5!!),saw inittab many times and i searced on the web for any similar problems...i cannot understand what is going on! I wait for the login prompt and....wait...and wait...what could be the problem? Has anybody encountered the same problem ever?
    Thanks in advance
    Is that the place where I am supposed to say sth clever and brilliant so that everybody understands how clever nice guy I am????
    Screw you guys I am going home!-Kartman

  2. #2
    Senior Member
    Join Date
    Nov 2001
    Posts
    1,255
    Has it occurred to you to look at your logs to see if getty is complaining about anything?
    Chris Shepherd
    The Nelson-Shepherd cutoff: The point at which you realise someone is an idiot while trying to help them.
    \"Well as far as the spelling, I speak fluently both your native languages. Do you even can try spell mine ?\" -- Failed Insult
    Is your whole family retarded, or did they just catch it from you?

  3. #3
    Senior Member
    Join Date
    Dec 2003
    Posts
    121
    I saw the var/log/boot messages but getty is not complaining about anything...the reason i know it wont start is because when i enter runlevel 1 and exec the command: getty 38400 tty2 it wont give me again a (second) console with a login prompt and it wont even run as a process(ps -a)
    What the problem seems to be is that either getty wont start at all or it starts but when it gives the login prompt the command to start there is no respond...i also have to tell that when doing Alt+arrows (normally change consoles) i get a big black screen instead of the login prompt....isnt it really weird???Please help...
    Is that the place where I am supposed to say sth clever and brilliant so that everybody understands how clever nice guy I am????
    Screw you guys I am going home!-Kartman

  4. #4
    Senior Member
    Join Date
    Nov 2001
    Posts
    1,255
    The syntax would seem to be off. You appear to be trying to use agetty syntax with getty.
    Slackware uses agetty by default, using the following syntax:
    agetty 38400 tty2 linux

    Getty uses the following syntax:
    getty tty2 38400
    Chris Shepherd
    The Nelson-Shepherd cutoff: The point at which you realise someone is an idiot while trying to help them.
    \"Well as far as the spelling, I speak fluently both your native languages. Do you even can try spell mine ?\" -- Failed Insult
    Is your whole family retarded, or did they just catch it from you?

  5. #5
    Senior Member
    Join Date
    Dec 2003
    Posts
    121
    Ok i finally found the problem (a friend more precisely)..i did not have devfsd so the tty 's would not load when the kernel was booting..now i only have to 'persuade' the computer to recognize my modem (/dev/s...sth does not exist) and then i will be ok! By the way i dont like widowmaker (!) do wou have anything better to propose? For god's sake dont tell me KDE or GNOME!Is enlightement good???
    Anyway thanks chsh
    Is that the place where I am supposed to say sth clever and brilliant so that everybody understands how clever nice guy I am????
    Screw you guys I am going home!-Kartman

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •