Introduction: I am a newbie in this site. I am already in debts and now hard disk crashed. I donít have enough money to buy any recovery software or new hard disk. Please help me out.

CELERON 2 GHz,128 MB RAM, 60 GB Hard Disk (Samsung), Mercury 845 GLM Main board. Windows 98se installed with Linux (Mandrake 9.1).
Hard disk crashed.

Recently I have installed soft-ice for windows95. I am practicing Assemble language using both TASM and A86 assemblers (I know they are old). I wrote a little program for printing a character ďA ďon the dos screen. The code is:


MOV AH,02h
MOV DL,41h

INT 21h
INT 20h

When complied it in TASM it gave an .obj and on linking it by using
TLINK filename.obj it gave an exe file when I clicked it the computer hanged.
I pressed ctrl+alt+del once instead of showing end task panel the computer restarted.
I then complied the above code with A86,the result was fine. On the same day I installed a game prince of Persia. I played it and it worked fine. But when I restarted the system my computerís VGA was gone. I reinstalled the VGA. I again played the game. Then was unzipping a game metal gear solid suddenly the electricity went off. After that when I restarted my system, nothing worked. Windows did not load. I tried safe mode but it didnít work. I used a bootable disk to start my system. C:,F:,G: drives were fine, but when got to D: and E: drives and wrote Dir the label of drive was an ASCII Symbol( a face, Arrows etc.) and also it gave a message:
Data Error
I then installed an another hard disk(Seagate) and made it primary master and the hard disk( Samsung) that gave error as Secondary slave for accessing the drives of this hard disk. But on restarting the computer only a blue background of desktop appeared without any icon . On pressing ctrl+alt+del end task panel appeared with explorer not responding. I restarted my computer same thing happened again. I then used bootable disk to start the computer. Then I got to the D: E: drives same thing happened and in addition to that F: drive also started giving the same error.
Data Error
The tried to paste a small text file in these drives but it gave error.
Canít access or create directory in f:
It this problem due to assemble code or soft-ice or Linux or the games ??
Please help me because I am in a great mess. I had many of my important documents on the hard disk. My job depends on them. Please kindly help