Stopping Ssh in SuSE 8.2
Results 1 to 6 of 6

Thread: Stopping Ssh in SuSE 8.2

  1. #1
    Right turn Clyde Nokia's Avatar
    Join Date
    Aug 2003
    Location
    Button Moon
    Posts
    1,696

    Stopping Ssh in SuSE 8.2

    Hi,

    I have a dual boot pc with Win XP and SuSE 8.2 home, I have only recently installed the Linux installation and am still getting to grips with it.

    the PC is on a small home network, I have just scanned the PC using my laptop with GFI LANguard and noticed that port 22 was open (Ssh) , I "Putty'd" into it and obviously as I know the root passwd, I had root in a few seconds, my line of thinking now is that if I can do it someone else can do it too!

    I have no need for this service and would like to disable it!

    I have just spent the last hour trying to disable this Ssh server but i cant find the bloody thing anywhere, could anyone let me know how to close port 22 and disable Ssh?

    Thanks in advance!

    \\also port 111 (SunRPC) is open, do I need this open and if i do what does it do?
    Im just about to go and google this but thought i would ask here aswell

    Thanks!
    Drugs have taught an entire generation of kids the metric system.

    http://tazforum.**********.com/

  2. #2
    Super Moderator
    Know-it-All Master Beaver

    Join Date
    Jan 2003
    Posts
    3,914
    Hey Hey,

    Since no one has answered you and I'm on a short break between classes.. I'll throw ya a short answer.

    check in /etc/x.inetd you'll find SSH in there just disable it from there (look at the syntax of the file and you'll figure it out)... If you need more help let me know and i'll tell ya how to do it, but I'd rather point ya in the right direction and let you learn for yourself.... You could also use YaST to disable SSH

    Peace,
    HT
    IT Blog: .:Computer Defense:.
    PnCHd (Pronounced Pinched): Acronym - Point 'n Click Hacked. As in: "That website was pinched" or "The skiddie pinched my computer because I forgot to patch".

  3. #3
    Senior Member
    Join Date
    Apr 2004
    Posts
    1,130
    comment ssh entry at /etc/xinetd.conf and restart service
    Meu sítio

    FORMAT C: Yes ...Yes??? ...Nooooo!!! ^C ^C ^C ^C ^C
    If I die before I sleep, I pray the Lord my soul to encrypt.
    If I die before I wake, I pray the Lord my soul to brake.

  4. #4
    Right turn Clyde Nokia's Avatar
    Join Date
    Aug 2003
    Location
    Button Moon
    Posts
    1,696
    hey, that sorted it!
    Thanks guys!
    Drugs have taught an entire generation of kids the metric system.

    http://tazforum.**********.com/

  5. #5
    AO BOFH: Luser Abuser BModeratorFH gore's Avatar
    Join Date
    Oct 2002
    Location
    Michigan
    Posts
    7,177
    For future reference, turning of services in SuSE Linux is easy:

    Open YAST2, go to the run level editor, and open up the properties, and shut down any services you want to in it.
    Kill the lights, let the candles burn behind the pumpkins’ mischievous grins, and let the skeletons dance. For one thing is certain, The Misfits have returned and once again everyday is Halloween.The Misfits FreeBSD
    Cannibal Holocaust
    SuSE Linux
    Slackware Linux

  6. #6
    Antionline's Security Dude instronics's Avatar
    Join Date
    Dec 2002
    Posts
    901
    In addition to all that, in SuSE Linux, you can stop/start every service (well, almost 'every') by logging into a shell as root, then:
    rcsshd start/stop to start/stop the ssh daemon
    rcpostfix start/stop to start/stop postfix
    rcblablabla start/stop etc......

    Cheers.
    Ubuntu-: Means in African : "Im too dumb to use Slackware"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •