power off when shutting down in RH9 & stop x
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: power off when shutting down in RH9 & stop x

  1. #1

    power off when shutting down in RH9 & stop x

    hi all,

    i'm having problems with powering off RH9 on my dual-boot system with windows xp.

    when i type the command: shutdown -h now, the system shuts down as usual, but when it is finished it says power down, but it won't power down the system automatically, how can i solve this??

    **EDIT** by the way, windows xp does power down the system, so my bios settings are correct **EDIT**


    also another question, you have the command startx to start the gui, but is there a way to stop the gui? i need this to install the latest video driver for nvidia, and i solved this problem by:
    rm -f /tmp/X0-lock
    kill xinitd
    kill xfs
    kill X

    but i'm pretty convinced there must be an easier way to do this, i've searched google for both this problems, but i can't find any relevant information....

    thanks in advance for any replies..



    grtz


    lepricaun

  2. #2
    Just a Virtualized Geek MrLinus's Avatar
    Join Date
    Sep 2001
    Location
    Redondo Beach, CA
    Posts
    7,324
    Try typing poweroff.

    edit

    you have the command startx to start the gui, but is there a way to stop the gui?
    Couple of ways:

    init 3

    OR

    Use the other 3 finger salute: ctrl+alt+backspace
    Goodbye, Mittens (1992-2008). My pillow will be cold without your purring beside my head
    Extra! Extra! Get your FREE copy of Insight Newsletter||MsMittens' HomePage

  3. #3
    Trumpet-Eared Gentoo Freak
    Join Date
    Jan 2003
    Posts
    992
    You might need to check ACPI and APM presence in the kernel.
    Come and check out our wargame-site @ http://www.rootcontest.org
    We chat @ irc.smdc-network.org #lobby

  4. #4
    You might need to check ACPI and APM presence in the kernel.
    they are present, the stangest thing is, that it had worked right after the install, but i must have changed something or so, since it doesn't work anymore

    i'll try typing poweroff, and i'll try the rest as well....

  5. #5
    Trumpet-Eared Gentoo Freak
    Join Date
    Jan 2003
    Posts
    992
    If it worked after the install then you definetly misconfigured something. Check you Control Center.
    Come and check out our wargame-site @ http://www.rootcontest.org
    We chat @ irc.smdc-network.org #lobby

  6. #6
    If it worked after the install then you definetly misconfigured something. Check you Control Center.
    the only thing i can think of is one of the services, but as far as i know, the ones i've disabled, i've enabled them again, so that should not be a problem....

    which services do i need for power off?

  7. #7
    Trumpet-Eared Gentoo Freak
    Join Date
    Jan 2003
    Posts
    992
    I assume RH uses the Grub bootloader (so far i know) and try to turn it on via your bootloader.

    #mount /boot
    - Look for the grub.conf, mostly in /boot/grub/grub.conf
    - Add "acpi=on" in the kernel line.

    For ex. this is a section of my grub, but i added the acpi thingie to show where to put it :

    Code:
     
    #Gentoo - Kernel 2.6.6-rc1
    title=Gentoo Linux - Kernel 2.6.6-rc1
    root (hd1,0)
    kernel (hd1,0)/bzImage2.6.6 root=/dev/ram0 init=/linuxrc real_root=/dev/hdc3 vga=0x317 acpi=on
    initrd (hd1,0)/initrd-2.6.6-rc1
    Hope this helps,
    Come and check out our wargame-site @ http://www.rootcontest.org
    We chat @ irc.smdc-network.org #lobby

  8. #8
    Custom User
    Join Date
    Oct 2001
    Posts
    503
    Depending on what window manager you are using, there is normally a way to exit x; usually via some menu item or whathaveyou. If you are running gnome (which I seriously doubt) then you just access the main menu then choose logout (AFAIR) should be something similar for KDE.

    Window managers such as blackbox usually allow you to define your own menus completely so having that sort of option would depend on you having put it/left it in your menu config. But basically, I would check the site for your window manager.

    I know this isn't what you want, but if you ever need to bring the console up while you are running x or require more consoles, you can press [ctrl]-[shift]-[f#] (f# being one of the f keys [i.e. F1, F2, etc]) and a new console will come up.

    ac

  9. #9
    Just a Virtualized Geek MrLinus's Avatar
    Join Date
    Sep 2001
    Location
    Redondo Beach, CA
    Posts
    7,324
    Depending on what window manager you are using, there is normally a way to exit x; usually via some menu item or whathaveyou. If you are running gnome (which I seriously doubt) then you just access the main menu then choose logout (AFAIR) should be something similar for KDE.
    This will only work if your default init is 3. If your default init is 5 then it will log out of the session but not out of XWindows.
    Goodbye, Mittens (1992-2008). My pillow will be cold without your purring beside my head
    Extra! Extra! Get your FREE copy of Insight Newsletter||MsMittens' HomePage

  10. #10
    Depending on what window manager you are using, there is normally a way to exit x; usually via some menu item or whathaveyou. If you are running gnome (which I seriously doubt) then you just access the main menu then choose logout (AFAIR) should be something similar for KDE
    i'm running gnome , that didn work either, since i automatically boot x when i log in again how can i change this, so that x isn started automatically, and i have to type startx to start it?

    This will only work if your default init is 3. If your default init is 5 then it will log out of the session but not out of XWindows.
    how do i know which is default?

    as for the shutdown problem: i've tried the poweroff command, and i've tried adding "acpi=on" in the bootloader (grub) but both of the things don 't work....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •