Need help from Redhat users!
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Need help from Redhat users!

  1. #1
    Member
    Join Date
    Apr 2004
    Posts
    92

    Unhappy Need help from Redhat users!

    Goodday.

    OS: Redhat 9

    Harddisk : FAT
    Need help becoz i couldnt really get users to write data into my FAT formatted harddisk.
    i have aready mounted hdb5 (which is the FAT harddisk) to a folder call "windows"

    Only Root have RWX permission on FAT windows.
    [root@localhost mnt]# ls -l windows
    total 4
    drwxr-xr-x 2 root root 4096 Jun 8 00:58 Recycled

    I want to allow user to have Write permission on the harddisk as well.
    [root@localhost mnt]# chmod u=rwx windows

    [root@localhost mnt]# ls -l windows
    total 4
    drwxr-xr-x 2 root root 4096 Jun 8 00:58 Recycled

    But it doesnt work

    I tried to change ownership to a user call novkhan but it doesnt work as well!

    [root@localhost mnt]# chown novkhan windows
    chown: changing ownership of `windows': Operation not permitted
    [root@localhost mnt]# ls -l windows
    total 4
    drwxr-xr-x 2 root root 4096 Jun 8 00:58 Recycled

    I hope to achieve WRX for all users on my FAT Harddisk.

    drwxr-wxr-wxr

    please help !
    Thankyou!
    Will to Learn
    javascript:myimagepopup(300,400,\'\')

  2. #2
    Senior Member
    Join Date
    Dec 2003
    Location
    Pacific Northwest
    Posts
    1,675
    novkhan,

    I have never tried to do this before (to a fat), but doesn't it work the same as any other directory or file:

    If the directory was named "sandy"

    chmod 777 sandy

    **the result should be: drwxrwxrwx

    chmod 755 sandy

    **the result should be: drwxr-xr-x

    chmod 700 sandy

    **the result should be: drwx------

    chmod 644 sandy

    **the result shoud be: drw--r--r--

    and: chmod 000 sandy

    **the result should be: d---------

    Connection refused, try again later.

  3. #3
    Member
    Join Date
    Apr 2004
    Posts
    92
    Originally posted here by Relyt
    novkhan,

    I have never tried to do this before (to a fat), but doesn't it work the same as any other directory or file:

    If the directory was named "sandy"

    chmod 777 sandy

    **the result should be: drwxrwxrwx

    chmod 755 sandy

    **the result should be: drwxr-xr-x

    chmod 700 sandy

    **the result should be: drwx------

    chmod 644 sandy

    **the result shoud be: drw--r--r--

    and: chmod 000 sandy

    **the result should be: d---------


    [root@localhost mnt]# chmod 777 windows
    chmod: changing permissions of `windows' (requested: 0777, actual: 0755): Operation not permitted
    Will to Learn
    javascript:myimagepopup(300,400,\'\')

  4. #4
    try "chown /mnt/windows root" first, and then the chmod command, i've seen this problem before with some things i've downloaded, but after the chown command it worked...

  5. #5
    Member
    Join Date
    Apr 2004
    Posts
    92
    Originally posted here by lepricaun
    try "chown /mnt/windows root" first, and then the chmod command, i've seen this problem before with some things i've downloaded, but after the chown command it worked...
    [root@localhost mnt]# chown /mnt/windows root
    chown: `/mnt/windows': invalid user
    [root@localhost mnt]# chown /mnt/windows novkhan
    chown: `/mnt/windows': invalid user
    [root@localhost mnt]#


    Will to Learn
    javascript:myimagepopup(300,400,\'\')

  6. #6
    Senior Member
    Join Date
    Sep 2003
    Posts
    500
    First off, why is the partition fat? Second, give each user a folder and then set permissions for each users

    chmod 755 /mnt/windows/sandy
    chmod 755 /mnt/windows/mike
    etc...

    I'm still curious as to why the partition is FAT
    You shall no longer take things at second or third hand,
    nor look through the eyes of the dead...You shall listen to all
    sides and filter them for your self.
    -Walt Whitman-

  7. #7
    Antionline Herpetologist
    Join Date
    Aug 2001
    Posts
    1,165
    chmod won't cut it here. You have to either specify the option "user" when mounting the partition (or in fstab) or (better option) add a valid umask to the fstab file. "man mount" should do the trick.

    Cheers,
    cgkanchi
    Buy the Snakes of India book, support research and education (sorry the website has been discontinued)
    My blog: http://biology000.blogspot.com

  8. #8
    Senior Member
    Join Date
    Dec 2003
    Location
    Pacific Northwest
    Posts
    1,675
    cgkanchi

    Hey thanks, not having experimented with it before, is that because we are mounting a partition verses just a file or directory?

    Connection refused, try again later.

  9. #9
    Antionline Herpetologist
    Join Date
    Aug 2001
    Posts
    1,165
    Relyt,
    Sort of. When you mount a device, Linux resets the permissions of the directory to whatever is specified in the fstab file for that file. If the fstab file is empty or says "defaults" in the options section, Linux will only allow root to read and write to and from that device.

    Cheers,
    cgkanchi
    Buy the Snakes of India book, support research and education (sorry the website has been discontinued)
    My blog: http://biology000.blogspot.com

  10. #10
    Senior Member
    Join Date
    Dec 2003
    Location
    Pacific Northwest
    Posts
    1,675
    cgkanchi,

    Thanks, for the explanation.

    Linux resets the permissions of the directory to whatever is specified in the fstab file for that file. If the fstab file is empty or says "defaults" in the options section, Linux will only allow root to read and write to and from that device.
    You have to either specify the option "user" when mounting the partition (or in fstab) or (better option) add a valid umask to the fstab file. "man mount"
    That makes sense and is hereby stored in the brain bank for later withdraw.

    cheers
    Connection refused, try again later.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •