You're hard disk is formatted with FAT32. Permissions can only be set on NTFS partitions. Either format your computer as NTFS and reinstall XP or use the convert command to change FAT32 to NTFS. Also, you will have to disable Simple File Sharing.

Cheers,
cgkanchi