freebsd newbie
Results 1 to 4 of 4

Thread: freebsd newbie

  1. #1
    Senior Member cwk9's Avatar
    Join Date
    Feb 2002
    Posts
    1,211

    freebsd newbie

    I had an unused computer lying around so I decided to try freebsd. Everything is working great except for one small problem I have yet to solve. Apache will not start on boot. If I go to /usr/etc/local/rc.d/ and type “./apache2.sh start” it starts fine and everything works as it should. The script was the default one that was installed with apache. Is there something that needs to be modified with the script or some other file before it will work on boot?

    A quick flip through the handbook and I discovered /etc/rc.local. Sounded promising so I plug in “sh /usr/local/etc/rc.d/apache2.sh start” and rebooted. No dice. That command looked a bit odd so I gave “/usr/local/sbin/apachectl start” a try. Still no luck. I get the feeling this is one of those problems where the answer is staring me right in the face.

    A few other notes about my setup.
    -mysql and webmin both start fine at boot
    -freebsd 4.10
    -I believe I used pkg_add to install it apache

  2. #2
    Banned
    Join Date
    Apr 2003
    Posts
    3,839
    Sorry im no *nix literate person but:

    http://www.webmasterworld.com/forum40/721.htm

    If you haven't already done so, you should add starting up Apache to your system startup files. I have the following in /etc/rc.local, although I'm sure there are more 'proper' ways of doing it (feel free to drop me a note with a suggestion)
    Code:
        #
        # Fire Up Apache
        #
        if [ -f /usr/local/apache/bin/apachectl ]; then
            /usr/local/apache/bin/apachectl start
        fi
    for 3.3 though, hope those help you somewhat

    http://freebsd.lanfear.com/howtos/frontpage.html

  3. #3
    Trumpet-Eared Gentoo Freak
    Join Date
    Jan 2003
    Posts
    992
    Do an "ls -la" in the /usr/etc/local/rc.d/ dir qnd check if that script is executable.

    You can see that by the x in the properties line of a file
    Code:
    -rwxr-xr-x   1 root root 1286 May 29 00:54 sshd
    If its not try #chmod +x <file> and reboot ...

    Greetz,
    Come and check out our wargame-site @ http://www.rootcontest.org
    We chat @ irc.smdc-network.org #lobby

  4. #4
    Senior Member cwk9's Avatar
    Join Date
    Feb 2002
    Posts
    1,211
    Both good suggestions but still no luck. Think I’ll try reinstalling from the ports collection when I have a moment.
    Its not software piracy. I’m just making multiple off site backups.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •