Drives in Linux.
Results 1 to 7 of 7

Thread: Drives in Linux.

  1. #1
    Senior Member
    Join Date
    Jun 2004
    Posts
    112

    Drives in Linux.

    I know that I have been asking a lot of newbie questions about LInux but I am trying to learn as much as I can while I get my system up and running correctly. I was wondering what I need to do to get my DVD player and CD burner working under Slack. I know I am going to have to edit my /etc/fstab file but I don't know what to add or what symbolic links in the /dev folder I need to create or to delete. I have already added hdc=ide-scsi for my cd burner in the append thing when I installed. (Gotta love HOWTO files!).

  2. #2
    One question before I can answer you in specifics (and yes, it matters guys, so don't be tossing him a bunch of half answers)

    Is your dvdplayer and cdrom on the same drive, or seperate?

  3. #3
    Senior Member
    Join Date
    Jun 2004
    Posts
    112
    They are completely seperate drives. I deleted the old links to /dev/cdrom and /dev/dvd because I was pretty sure that starting from scratch would be easier and was needed. I linked /dev/cdrom and /dev/sr0 together and /dev/hdd and /dev/dvd also. I then linked /devdvd and /dev/cdrom with their corresponding mount directories. Is that right? I also worked on it a while last night and I got all the links created and I have a kind of test Fstab file ( I used the same stuff for both) they can mount and eject and stuff but if I can just get the two entries for ftab it would be great! Here is what I have (I know it is wrong but I was testing to see if my links worked):

    /dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
    /dev/dvd /mnt/dvd iso9660 noauto,owner,ro 0 0

  4. #4
    I deleted the old links to /dev/cdrom and /dev/dvd because I was pretty sure that starting from scratch would be easier and was needed.
    Correct!

    I linked /dev/cdrom and /dev/sr0 together
    Correct! Glad you remembered to use sr0 instead of hdc!

    and /dev/hdd and /dev/dvd also.
    Correct correct!

    I then linked /devdvd and /dev/cdrom with their corresponding mount directories.
    No no no no no no no. Never link those Mount handles that part on it's own. Unlink them or else you may have quite a few disasters in future situations.

    /dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
    /dev/dvd /mnt/dvd iso9660 noauto,owner,ro 0 0
    Not bad, here is what would work perfectly:

    /dev/cdrom /mnt/cdrom iso9660 noauto,user,ro 0 0
    /dev/dvd /mnt/dvd auto noauto,user,ro 0 0
    We want to change both instances of 'owner' to 'user', that way everyone in the 'user' group can mount and unmount them without needing a pesky su root. We also change iso9660 from itself to auto on the dvd, because it -won't- be just iso9660 cds, but dvd as well. After that, the fstab forh both should work fine

    As a final note, umount both drives and run these commands in su root:

    chmod 777 /mnt/dvd*
    chmod 777 /mnt/cdrom*
    chgrp wheel /mnt/cdrom*
    chgrp wheel /mnt/dvd*
    That way your normal programs have priviledged access to read (you still need to su root to write cd's) and execute things on the cd's, as well as mount.

    After that, see if everything works We can discuss using hdparm later to enable DMA and a few other speed features on your dvd and hda drive.

  5. #5
    Senior Member
    Join Date
    Jun 2004
    Posts
    112
    I changed the things that you said and everything worked great. The only thing I noticed was that with totem the dvd playback was a little bit laggy. This machine is not very speedy but it is more than capable to handle dvd playback I am quite sure (worked when I had Windows on it). Setting the dvd drive and my HD to DMA mode should help boost performance a bit in this department right? Thanks so far!

  6. #6
    This machine is not very speedy but it is more than capable to handle dvd playback I am quite sure
    Correct. Windows handles the DMA and optimizes your drive already, while Linux merely plays it safe and only turns on one or two things.

    Once we use hdparm to turn on a few safe settings (let me know if you need help with that) on both your dvd rom and hda, not only will your dvd not skip, but a general speed in OS preformance as well. Remember to add the entire hdparm + parameters to your rc.local so they set themselves each time.

    note: your cd writer since it is scsi emulated can NOT use hdparm

  7. #7
    Senior Member
    Join Date
    Jun 2004
    Posts
    112
    I went into single user mode and played around with hdparm and with /dev/hda I tested it before trying anything with ----> hdparm -Tt /dev/hda

    The output I got was: Timing buffer-cache reads: 128 MB in 1.06 seconds = 120.75 MB/sec
    Timing buffered disk reads: 64 MB in 5.06 seconds = 12.65 MB/sec

    This didn't seem too terribly bad. DMA is on and multcount is set at 16. Here is where I get frustrated I turned other settings on (IO_support to 32bit w/sync instead of 16bit, and others) but I still cannot get any higher than the 12.65. Is this all that the drive can get? Surely not. I also don't really know what to do about my DVD drive settings either. All help will be greatly appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •