IIS/PHP For Windows 2000 Server Problem
Results 1 to 4 of 4

Thread: IIS/PHP For Windows 2000 Server Problem

  1. #1
    Junior Member
    Join Date
    Feb 2004
    Posts
    10

    IIS/PHP For Windows 2000 Server Problem

    Hello,
    Im using Microsoft Information Services that came with windows 2000 Server to host my web page. and it does a great job of hosting .HTML / .HTM stuff, but im having a problem getting it to open .PHP documents, I installed PHP on the server and when i try to open a PHP document through the server on a different computer it comes up with a 403.1 (Execute Access Forbidden) Message, and when i try to open the PHP documents directally on the server it gives me that open with dialog window, someone help.............
    |Ex.G| Shadow

  2. #2
    AO Decepticon CXGJarrod's Avatar
    Join Date
    Jul 2002
    Posts
    2,038
    Couple of questions. Where did you get the install for PHP?

    Did you create an ISAPI filter (to the DLL so PHP will run) as shown here:

    http://www.onlamp.com/pub/a/php/2000...php_admin.html
    N00b> STFU i r teh 1337 (english: You must be mistaken, good sir or madam. I believe myself to be quite a good player. On an unrelated matter, I also apparently enjoy math.)

  3. #3
    Junior Member
    Join Date
    Dec 2002
    Posts
    27
    u need a permission to run a php page.. open your IIS and right click on folder which include php file and select properties. look at directory tab and check "write" checkbox. then look at directory security tab and click at edit button. u must check checkbox for anynomous access. it let the other user run your php script.

    if u dont understand it. PM me. tx
    Lord Xavier,
    Cyberdelia Technologies,
    (Wholly owned by Cyberdelia Group).

  4. #4
    Hmmm, the questions were not really answered.

    I have installed PHP on IIS before, and for your info for later, PHP5 does not install on IIS as a CGI... that's a known problem atm. Anyhoo, if you wanna install PHP4.x, here's how you do it on a win2k/xp box:

    Install the PHP binaries or use the installer foud on http://php.net. On the installer, it is a CGI by default, and does not come with the extensions, you will have to install those by hand. (pdf, etc) Then make sure the path to your php executable is in php.ini (make sure that is in your system root) and if you have not installed your database server, you might want to do that as well. I use MySQL, and works great.

    Then open IIS in your admin panel, and choose the web site you wish to run PHP documetns on. This is achieved by right clicking over the Default Web Site (or whatever you called it) and choose properties. Then choose the "Home Directory" tab and click the configutation button. There, you will see where all your scripts and other **** is called.

    Click the add button. There, you will choose where to find the php.exe file, then mak sure the extension is .php, .php3, or .php5 or whatever you want to call your files. I chose .php. Then click the "check to see if executable exists. Close the dialog after hitting OK. Close the box.

    Then choose the Document tab, and then click "add." from there, type index.php and put that on the top of the list.

    yay! Your PHP should work now. If you have problems, please let me know, or ask me about my web site.

    Jack

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 Security News

     Patches

       Security Trends

         How-To

           Buying Guides