Another internet connection problem - linux
Results 1 to 9 of 9

Thread: Another internet connection problem - linux

  1. #1
    Member
    Join Date
    Aug 2001
    Posts
    90

    Exclamation Another internet connection problem - linux

    It's been a long long while since I posted anything, so this is as good a time as any.

    heh heh.

    On with the question:

    I recently (read: day before yesterday) installed Red Hat 9 on my test box. The box came with an internal modem. Now, since previous experience with Linux has shown me that internal modems aren't usually supported ( the whole winmodem thing comes to mind ) I decided to get me an external modem. Sneaking into my friends house I unplugged his U.S. Robotics 56K modem, and then inserted my internal modem into his PC. heh heh sneaky sneaky. He knows now, though.

    On startup, the Hardware detection tool in linux (forgot the name) noticed the modem, and installed it as a Generic Modem (External).

    Logged in as root, fired up X Windows and set up a connection using KDE's dailer ( KPPP, I think it is ). Probing the modem got back results, a bunch of ACKs accomplished or some such.

    Now heres the issue; the connection can be esablished. The modem dails in the number, it makes those funny dial-up noises, and it gets assigned an IP address. But it ends there. I am unable to ping any address. Mozilla goes nowhere. IRC doesn't connect. Nothing.

    Any ideas on what is going on here?

    Is this information enough?
    I blame you cos my mind is not my own, so don't blame me if I trespass in your zone!

  2. #2
    Senior Member
    Join Date
    Jan 2003
    Posts
    3,914
    Hey Hey,

    When you say address do you mean IP Address or Domain Name? If you are typing www.google.ca... try 64.233.167.104 (one of Google's IP Addresses). See if you get a reply with that.. it may just be a problem with not getting your Name Servers Properly.. if you get a reply from pinging the address go to /etc/resolv.conf and set your name servers yourself.

    Have you checked your log files? /var/log may point you in the right direction.. check messages or for a ppp log of some sort.

    Do you also have a network card installed? If so try ping -I ppp0 (or whatever device your modem is reading as) and see if that works...

    Also if you could paste a complete ifconfig that may be beneficial... unless it's something simple that i'm overlooking because I'm tired

    Also internal modems are fairly simple to get working in Linux these days.. even most Winmodems are supported.


    Peace,
    HT
    IT Blog: .:Computer Defense:.
    PnCHd (Pronounced Pinched): Acronym - Point 'n Click Hacked. As in: "That website was pinched" or "The skiddie pinched my computer because I forgot to patch".

  3. #3
    Antionline Herpetologist
    Join Date
    Aug 2001
    Posts
    1,165
    To build on what HT said, you need to tell your computer where to find the DNS servers. If you don't know what they are, you can find the information in the TCP/IP settings under Windows and add those IP's to your /etc/resolv.conf

    Cheers,
    cgkanchi
    Buy the Snakes of India book, support research and education (sorry the website has been discontinued)
    My blog: http://biology000.blogspot.com

  4. #4
    Member
    Join Date
    Aug 2001
    Posts
    90
    My ISP has no DNS settings under windows. They're 'auto-detect'ed I think. The Primary and Secondary DNS fields are empty (under windows)

    I have windows XP running alongside my linux box, connected to a KVM switch. Just thought i'd let you know.
    I blame you cos my mind is not my own, so don't blame me if I trespass in your zone!

  5. #5
    Senior Member
    Join Date
    Jan 2003
    Posts
    3,914
    Originally posted here by RejectKnowledge
    My ISP has no DNS settings under windows. They're 'auto-detect'ed I think. The Primary and Secondary DNS fields are empty (under windows)

    I have windows XP running alongside my linux box, connected to a KVM switch. Just thought i'd let you know.
    Even if DHCP provides your DNS settings.. you still have DNS Servers to access... Check your connection properties after you connect. What we're saying is that they might not be properly providing them to your linux box and you may have to set them manually...

    Peace,
    HT
    IT Blog: .:Computer Defense:.
    PnCHd (Pronounced Pinched): Acronym - Point 'n Click Hacked. As in: "That website was pinched" or "The skiddie pinched my computer because I forgot to patch".

  6. #6
    Member
    Join Date
    Aug 2001
    Posts
    90
    Connection properties?

    Are you referring to the 'Details' tab in the connection status? Thats where it mentions my IP and other stuff. It will give me a DNS server. Should I manually add this DNS server address to my /etc/resolv.conf file?

    I'm asking because this is probably just one of the DNS servers that my ISP uses..
    I blame you cos my mind is not my own, so don't blame me if I trespass in your zone!

  7. #7
    Senior Member
    Join Date
    Jan 2003
    Posts
    3,914
    Hey Hey,

    Yes under connection status.. You should usually see two DNS servers listed there.... regardless of how many DNS servers your ISP may use... those are the only two that you will query when connected, so it doesn't matter how many more they have.

    The context is nameserver <ip address>. Have you checked yet to see if /etc/resolv.conf already lists your name servers?

    Peace,
    HT
    IT Blog: .:Computer Defense:.
    PnCHd (Pronounced Pinched): Acronym - Point 'n Click Hacked. As in: "That website was pinched" or "The skiddie pinched my computer because I forgot to patch".

  8. #8
    Member
    Join Date
    Aug 2001
    Posts
    90
    There are no nameservers in /etc/resolv.conf

    Also, under TCP/IP settings for my connection in windows, the Primary and Secondary DNS fields are empty.

    The thing is, I'm getting connected to the net in linux. I'm even getting me an IP address. But thats it. Nothing else. No browsing, no pinging.
    I blame you cos my mind is not my own, so don't blame me if I trespass in your zone!

  9. #9
    Antionline's Security Dude instronics's Avatar
    Join Date
    Dec 2002
    Posts
    901
    Maybe a firewall problem? Try a: tail -f /var/log/messages and/or tail -f /var/log/'your-firewall-log' and see if its rejecting or dropping any packets. If your convinced that your firewall settings are ok, reload the firewall once you are connected. Sometimes the firewall has to be reloaded when using ppp0, since the ip is dynamic. Maybe also try switching of the firewall completely, only to see if thats' why you cant do anything once connected.

    Cheers.
    Ubuntu-: Means in African : "Im too dumb to use Slackware"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •