Linux - Server hosting is *really* laggy and unstable
Results 1 to 3 of 3

Thread: Linux - Server hosting is *really* laggy and unstable

  1. #1
    Junior Member
    Join Date
    Jul 2004
    Posts
    5

    Linux - Server hosting is *really* laggy and unstable

    I recently changed the OS running an Ultima Online server from Win 2k Server to Linux. Since that, the gameplay started lagging a lot more than normal, getting worse by the minute. The ping before I run it is around 140ms, and after, it's really inaccurate:

    Resposta de x.x.x.x: bytes=32 tempo=818ms TTL=50
    Resposta de x.x.x.x: bytes=32 tempo=170ms TTL=50
    Resposta de x.x.x.x: bytes=32 tempo=242ms TTL=50
    Resposta de x.x.x.x: bytes=32 tempo=242ms TTL=50
    What can I do to get the server to run well? The machine and connection is the same as when we ran Win2k.

    The server also shuts down by itself, and constantly complains about Tx errors and Main Loop freezing, which didnt happen before the OS change.

    One third thing (doesnt have to do with Linux) that screws our server a lot are occasional DoS attacks (mainly from banned users and their friends). It's a brazillian server, and everyone here seems to know how to perform one. What could I do to minimize these attacks? Authorities here don't seem to care much about internet crimes.

    Sphereserver 55i R4.02 (Red Hat 9)

  2. #2
    Senior Member
    Join Date
    Oct 2002
    Posts
    4,055
    Perhap's on your other machine you had a method/firewall/etc that helped slow down or calm the DoS attacks a little that you aren't using on your new OS. Also are you taking proper server maintance care? Make sure it's not a hardware issue (cooling/heating/etc). It could be literally a few reasons causing problem's. What I would do is look up any DoS vulnerabilities/holes that you could have on your OS that might be out there and then patch them. Eliminating or slowing down the amount of DoS attack's might help thing's or not, I'm not entirely sure.
    Space For Rent.. =]

  3. #3
    Junior Member
    Join Date
    Jul 2004
    Posts
    5
    Suddenly got better.
    It's stable, and after a restart, not lagging anymore =)

    I'm taking precautions against DoS attacks

    Thanks anyway man

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •