Thumb drive giving probs
Results 1 to 4 of 4

Thread: Thumb drive giving probs

  1. #1
    Junior Member
    Join Date
    Nov 2003

    Thumb drive giving probs

    Hi guys,
    My thumb drive is giving some trouble. I use an IOMega thumb
    drive of 128 MB capacity.
    Under WindowsXP it is getting detected but when i try to open
    it, it tells me "Please insert disk". I can neither format it. When i
    tried to format, in the format dialog box, the size is displayed as
    Neither under linux i'm able to format it. Moreover i dont
    exactly know how to format it under linux. My condition is pathetic.
    Need some help.


  2. #2
    Senior Member nihil's Avatar
    Join Date
    Jul 2003
    United Kingdom: Bridlington
    This is a pure guess, so please forgive me if I am wrong.

    Does the drive have a CD or 3.5" floppy disk...............if so, you may have to load that FIRST (without the device attached).

    USB is generically recognised in XP but certain devices want their own driver software (digital cameras are a good example) which has to be installed before you attach the device.

    There is also the possibility that the device is faulty...........have you tried it in other machines?

  3. #3
    King Tutorial-ankhamun
    Join Date
    Jul 2004
    Iíd say test it on a friends machine, if it does not work then take it back to where you bought it because thereís a 90% chance itís fubar.

  4. #4
    Join Date
    Nov 2003
    San Diego
    And if it does work try reinstalling the drivers.
    When death sleeps it dreams of you...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts