Mount help and Vim help in slack 9.1
Results 1 to 9 of 9

Thread: Mount help and Vim help in slack 9.1

  1. #1
    Senior Member
    Join Date
    Apr 2004
    Posts
    1,024

    Mount help and Vim help in slack 9.1

    I can't manage to mount my cdrom drive (it has a music cd in). I read the man page and it said the default FS is iso9660, and that is what a cd is, right? So i specified that with the options, and I am wondering what other options I need to specifiy. The error won't help any cuz it says something to the effect of "cannot mount because of somehting, something, and file system type", so it could be any of the differing things it noted. xmms will be able to play a music cd also, right? Also, the computer I am working with does have a good cd drive in, as that is what I installed slack off of, also, Win98 SE was on there before and the cd drive functioned correctly. Any other details you need? Anything hardware specific I might need to change to get it to work? I have NO idea what the jumper settings are, but I'm guessing it's set to single since thats what it is (all by itself on 2nd channel)

    Ok now to Vim. Anyone know of a listing of all Vim or Vi commands? I have the Oreilly linux in a nutshell book, but I am somewhat confused by the way they list command. If someone could clear up what the hell ^W then a key is I can probably get by without a tut or list, but I'm just getting confused so any help helps. <--that didn't make much sense but I can't figure out a way to write it making more sense, so just try to pull what you can out of it :P
    [H]ard|OCP <--Best hardware/gaming news out there--|
    pwned.nl <--Gamers will love this one --|
    Light a man a fire and you\'ll keep him warm for a day, Light a man ON fire and you\'ll keep him warm the rest of his life.

  2. #2
    Junior Member
    Join Date
    Aug 2004
    Posts
    6
    Hello,

    as far as i know it is not possible to mount an audio-cd cause there is no file system on it. iso9660 is the usual file system for data-cds and this can be mounted.

    For audio cds you have to use a application like xmms, i assume you know that program.

    Unfortunatly i cant really help you with your vi question cause i prefer emacs as an editor, but i did a google for you.


    Hope i could help at least a bit,


    greetz,

    current

    Bugs come in through open Windows.

  3. #3
    Junior Member
    Join Date
    Aug 2004
    Posts
    27
    Cant u just mount the cd-rom and then just play the CD's you put in it.

    command line: mount /dev/hdd (or whtever the cd-rom is in/dev, you can see that in the Hardwar Browser) /mnt/cdrom

    then just put the CD in and an icon should appear on ur desktop, then just go to xmms, Add-Dir-/mnt/cdrom

    i think that should work !

  4. #4
    BANNED
    Join Date
    Nov 2003
    Location
    San Diego
    Posts
    724
    Here's a page with Vim commands:
    http://www.tuxfiles.org/linuxhelp/vimcheat.html
    When death sleeps it dreams of you...

  5. #5
    Senior Member
    Join Date
    Apr 2004
    Posts
    1,024
    Originally posted here by current
    Hello,

    as far as i know it is not possible to mount an audio-cd cause there is no file system on it. iso9660 is the usual file system for data-cds and this can be mounted.

    For audio cds you have to use a application like xmms, i assume you know that program.

    Unfortunatly i cant really help you with your vi question cause i prefer emacs as an editor, but i did a google for you.


    Hope i could help at least a bit,


    greetz,

    current
    There is a file system on anything that can be read. xmms cannot read from the drive if it has not been mounted.

    Cant u just mount the cd-rom and then just play the CD's you put in it.

    command line: mount /dev/hdd (or whtever the cd-rom is in/dev, you can see that in the Hardwar Browser) /mnt/cdrom

    then just put the CD in and an icon should appear on ur desktop, then just go to xmms, Add-Dir-/mnt/cdrom

    i think that should work !
    No, no icons will show on desktop or anything. I will try mounting it then seeing if it will read the cd though. I am not using KDE or Gnome. Too resource heavy for this box. I'm using fvmm or whatever the one that starts with the f. I cannot remember the specifics of the name.

    Thanks for the link muerto.
    [H]ard|OCP <--Best hardware/gaming news out there--|
    pwned.nl <--Gamers will love this one --|
    Light a man a fire and you\'ll keep him warm for a day, Light a man ON fire and you\'ll keep him warm the rest of his life.

  6. #6
    BANNED
    Join Date
    Nov 2003
    Location
    San Diego
    Posts
    724
    As Colmcille has pointed out, you can't mount an audio CD. This is a point that
    threw me for a few hours when I was first messing around with Linux!

    To spell things out: 'mounting' means attaching the top-level directory
    of the file system on the CD to the mount point that you've specified
    (/media/cdrom) so that the subdirectories on the CD appear to be
    subdirectories of the mount point (say /media/cdrom/directory/subdir).
    With data CDs, the method you've tried should work - a data CD
    has a file system on it, generally the iso9660 system that you've
    specified. But an audio CD contains no file system - it's essentially
    a raw stream of data with a few other bits and pieces that say where
    tracks start and end. It doesn't have any files or subdirectories on it.
    You are telling the system to read this CD as an iso9660 file system, which
    it isn't; hence the problem!
    http://www.linuxformat.co.uk/modules...c=2245&forum=1
    What distro are you on? I'll try and help you figure out a way to play the cd.

    Edit: nm I read the title when I went to the frontpage. I'll post if I find something.
    But I think your answer might be in that link as well.
    When death sleeps it dreams of you...

  7. #7
    Senior Member
    Join Date
    Apr 2004
    Posts
    1,024
    Yea, the guy points out the problem but he doesn't give the answer. Damned people on other forums

    I guess current was right, I will try just using xmms, but I am unsure if that will work. I saw no way to select audio cd in there. hmpf. This is the first new os I have tried using since the dos/windows switch. So as you can guess it's thrashing me around pretty good. I'm getting there though.

    *edit* I'm going to bed, I won't have a chance to be back on here till sat, so I'll check back then. Thanks for the help guys. Good luck with your new account sk.
    [H]ard|OCP <--Best hardware/gaming news out there--|
    pwned.nl <--Gamers will love this one --|
    Light a man a fire and you\'ll keep him warm for a day, Light a man ON fire and you\'ll keep him warm the rest of his life.

  8. #8
    I assume you have figured it out already but if you haven't then I will tell you that ^W means [CTRL] + [W]. Thus, ^ = [CTRL]
    --> MyWebsite <--

  9. #9
    Junior Member
    Join Date
    Feb 2004
    Posts
    10
    If you want to play a n audio cd using xmms you don't need to mount it. All you need to do is make sure you have the 'CD Audio Player' input plugin which as far as I know is usually installed with xmms. Once the plugin is installed if it wasn't all you have to do to play a CD is go 'Play File' and navigate to the directory that your CD drive mounts at (ex: /mnt/cdrom usually). One further note you might want to enable 'digital audio extraction' in the CD Audio Player's plugin configuration if you do not have your CD drive connected to your sound card.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 Security News

     Patches

       Security Trends

         How-To

           Buying Guides