Fedora Core 2 wi-fi trouble
Results 1 to 3 of 3

Thread: Fedora Core 2 wi-fi trouble

  1. #1
    Member
    Join Date
    Jan 2004
    Posts
    63

    Fedora Core 2 wi-fi trouble

    I have absolutely no previous knowledge of linux, but I have managed to install it on my computer. I have been able to comfortable configure everything except the wireless access for my Intel 2200 B/G. For some reason I am still unable to configure it. I would appreciate any help in trying to fix it.

  2. #2
    Well, I installed Fedora Core 1 on my laptop a couple months ago, and ended up with a situation similar to yours. Actually I'm still in the process of sorting everything out. Apparently most people have this problem when they first start out with Linux. Anyway, after a quick Google, I found out where to get the drivers for this wireless card for Linux:

    http://ipw2200.sourceforge.net/

    Hope that helps.

  3. #3
    Senior Member
    Join Date
    Jun 2004
    Posts
    112
    Hey there buddy,
    First off, congrats on installing Linux for the first time. You really are in for a treat. Alright, down to business my boy.
    I know that this may seem lame but have you by chance downloaded the drivers for your card? Well, if you haven't here is a link to them:

    http://ipw2200.sourceforge.net/

    After you have obtained them start up your terminal (if you don't have one open already), and switch to the directory in which you have the source package. If you are unsure on how to do this, be sure that you read these small tutorials on *nix basics first:

    http://www.ee.surrey.ac.uk/Teaching/Unix/

    After you have gotten to the directory you will need to type this command:
    Code:
    % tar xzvf ipw2200-0.4.tgz
    After you have typed this change directories into ipw2200-0.4 and then type:
    Code:
    % make
    This will configure the build process for your kernel. You will next need to make sure that your kernel has support for firmware loading, to do this use the nifty grep tool:

    Code:
    grep CONFIG_NET_RADIO  /lib/modules/`uname -r`/build/include/linux/autoconf.h
    Hopefully what you should see is : #define CONFIG_NET_RADIO 1 . If you don't you will need to re-compile your kernel with support for it. Now you will need to get the firmware image, which can be found here:

    http://ipw2200.sf.net/firmware.php

    To be able to use firmware hotplug support you will need to have CONFIG_FW_LOADER enabled along with the above. Also you will need to have the latest hotplug scripts in /etc/hotplug/firmware.agent. To get them here is a link:
    http://sourceforge.net/project/showf...group_id=17679

    You will also need to have sysfs mounted. To do this all you have to do is add an entry to your /etc/fstab file that looks like this:
    Code:
    none            /sys            sysfs   defaults                0       0
    Also, if the /sys directory doesn't exist you will need to create it (read those tutorials I hope, I am leaving this one as a challenge for you.) Now you can mount the partition with the command: mount -a
    You should now be able to use the scripts provided with the package to load the driver without doing a make install.
    If you wish though it is really simple. In the directory with the source files (remember where we typed make earlier?)
    type:
    Code:
    % make install
    then...
    Code:
    % modprobe ipw2200
    You should now be up and running. If not come back here and post your questions.

    <edit>Whoops, look like you already posted the link to the drivers Nielsosky13, sry bout that. When I began my reply noone had posted </edit>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •