Apache Problems
Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Apache Problems

  1. #1
    Member
    Join Date
    Apr 2004
    Posts
    91

    Unhappy Apache Problems

    Everytime Ive installed Apache I always had a little difficulty making it work. I only edited the conf a little, and I knew what I was doing. Regardless of editing the conf, it wont work. When I try and start the server it gives me the error 'The requested operation has failed!' Ive tried changing listen ports, from my WAN IP, to my router IP and to 80, and so on. IIS is not running. Its being ran on WinXP SP2. Ive tried installing and reinstalling many times. But immediatly I get the error without messing with any config or setup files.

    The error log has this to say:

    [Thu Sep 16 16:59:48 2004] [notice] Parent: Created child process 1428
    [Thu Sep 16 16:59:48 2004] [crit] (OS 10050)A socket operation encountered a dead network. : alloc_listener: failed to get a socket for 0.0.0.0
    Syntax error on line 120 of C:/Program Files/Apache Group/Apache2/conf/httpd.conf:
    Listen setup failed
    [Thu Sep 16 16:59:49 2004] [crit] master_main: create child process failed. Exiting.
    [Thu Sep 16 16:59:49 2004] [notice] Parent: Forcing termination of child process 2538696

  2. #2
    Trumpet-Eared Gentoo Freak
    Join Date
    Jan 2003
    Posts
    992
    Could you post your conf ?
    Come and check out our wargame-site @ http://www.rootcontest.org
    We chat @ irc.smdc-network.org #lobby

  3. #3
    Just Another Geek
    Join Date
    Jul 2002
    Location
    Rotterdam, Netherlands
    Posts
    3,401
    Are you sure the WinXPSP2 firewall isn't blocking Apache's access?
    Oliver's Law:
    Experience is something you don't get until just after you need it.

  4. #4
    Member
    Join Date
    Apr 2004
    Posts
    91
    The conf is unedited from the moment its downloaded, but Ill post it anyway. Yes I turned the firewall off. I have McAffee installed, but completly disabled every part of it before trying Apache. For the purpose of being able to upload it, ive made it a txt, not a conf.

  5. #5
    Jaded Network Admin nebulus200's Avatar
    Join Date
    Jun 2002
    Posts
    1,356
    Not sure if this is a valid syntax or not:
    ServerName xxxxxxx13.xxx.xxx:80
    I think you should leave the port off of that one...

    That is the only thing that really jumped out at me; however, I have never attempted to run apache in a windows environment, so that probably isn't helping matters. Also, Apache, at least in an unix environment has a syntax checker:

    /usr/apache/bin/apachectl
    usage: /usr/apache/bin/apachectl (start|stop|restart|fullstatus|status|graceful|configtest|help)

    start - start httpd
    stop - stop httpd
    restart - restart httpd if running by sending a SIGHUP or start if
    not running
    fullstatus - dump a full status screen; requires lynx and mod_status enabled
    status - dump a short status screen; requires lynx and mod_status enabled
    graceful - do a graceful restart by sending a SIGUSR1 or start if not running
    configtest - do a configuration syntax test
    help - this screen



    run apachectl configtest

    If there is an issue with your configuration, this will be (usually) pretty helpful.


    The other thing that is interesting to me, is that it appears it is trying to determine an address to bind the listening socket to and it is coming back with 0.0.0.0 and is then bitching it is a dead network...You might want to under your 'Listen' directive, give your full IP along with the :80.

    Hope that helps.
    There is only one constant, one universal, it is the only real truth: causality. Action. Reaction. Cause and effect...There is no escape from it, we are forever slaves to it. Our only hope, our only peace is to understand it, to understand the 'why'. 'Why' is what separates us from them, you from me. 'Why' is the only real social power, without it you are powerless.

    (Merovingian - Matrix Reloaded)

  6. #6
    Member
    Join Date
    Apr 2004
    Posts
    91
    Ive tried every arangment as posibile with the listen port. 192.168.0.1, 192.168.0.1:80, 80, My IP, My IP:80. Everything. All of that unix text made no sense to me, so Ill just ignore it. In fact none of that made sense to me except the last paragraph about the listen port.

  7. #7
    Jaded Network Admin nebulus200's Avatar
    Join Date
    Jun 2002
    Posts
    1,356
    Originally posted here by philman213
    Ive tried every arangment as posibile with the listen port. 192.168.0.1, 192.168.0.1:80, 80, My IP, My IP:80. Everything. All of that unix text made no sense to me, so Ill just ignore it. In fact none of that made sense to me except the last paragraph about the listen port.
    There is a ServerName directive in your configuration file. You set the name with the port there. I wouldn't be the least bit suprised if this is what is causing your socket bind errors. As far as the listen port goes, if you continue to have problems with the socket not binding correctly, then I would consider doing that.

    What I was trying to say about the unix apache is that there is a utility there called apachectl that can be used to check the configuration of your .conf file. I was recommending you use it, it will likely point out the place in your configuration file that has the problem.

    But the more I think about it, the more that I am pretty sure your problem is because of the ServerName directive you used.
    There is only one constant, one universal, it is the only real truth: causality. Action. Reaction. Cause and effect...There is no escape from it, we are forever slaves to it. Our only hope, our only peace is to understand it, to understand the 'why'. 'Why' is what separates us from them, you from me. 'Why' is the only real social power, without it you are powerless.

    (Merovingian - Matrix Reloaded)

  8. #8
    Banned
    Join Date
    Sep 2004
    Posts
    305
    Describe how your network is set up please.

  9. #9
    Senior Member
    Join Date
    Mar 2002
    Posts
    502
    You're not, by any chance, using any McAfee products are you? They are known to cause problems for Apache. If you're using McAfee security, try disabling the Privacy Service.

    Something else, Apache uses "0.0.0.0" to indicate it listens on all interfaces, instead of a specific one.
    Bleh.

  10. #10
    Member
    Join Date
    Apr 2004
    Posts
    91
    My servername would be example.ath.cx:80, and listen 80. I guess that isnt correct..?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •