slackware problem with ALSA
Results 1 to 7 of 7

Thread: slackware problem with ALSA

  1. #1
    Senior Member
    Join Date
    Dec 2003
    Posts
    317

    slackware problem with ALSA

    Whenever i log into X, I have to run alsactl restore to hear any sound, i did an alsatl store after running alsa conf, but it still has this problem. I know it's not because it's muted because i've checked with alsamixer before i restore anything and everything is normal. The weird thing is that everything works normally outside of X. If I, for example: reboot my system and log in on my main account, i can listen to an mp3 with mpg123 without a problem, but if when i log into x, i'll have to restore my alsa settings for some reason. Anybody know why this is and how to fix it?

  2. #2
    Senior Member gore's Avatar
    Join Date
    Oct 2002
    Location
    Michigan
    Posts
    7,177
    First, do this:

    Log in as root in text mode:

    alsamixer

    Turn up Master and PCM, and make sure you have sound.

    alsactl store

    And next, go too http://www.slackware.com

    RTFM, it tells a lot about audio problems like this, and you HAVE too read it. You're not going to learn anything if someone does this for you. A hint:

    Look for where it talks about chmod on the *dsp whic is in the FAQ.

  3. #3
    Senior Member
    Join Date
    Dec 2003
    Posts
    317
    ok, ill do it, thnx

  4. #4
    Senior Member
    Join Date
    Dec 2003
    Posts
    317
    well, i did that first part again and for some reason the sound doesnt work at all now. I logged in as root, stayed in text mode, did an alsaconf, alsamixer, set the volumes how i wanted, alsactl store, and then i tried the sound with mpg123 and i get nothing. I'm guessing that what you were trying to tell me before was to do a chmod 666 on /dev/dsp* and and /dev/mixer* ? i had already done that, i the problem i was having was that my alsaconf settings were being reset to nothing whenever i started X (although now i have another problem )

  5. #5
    Senior Member
    Join Date
    Dec 2003
    Posts
    317
    nvm, i fixed the no sound problem, but the original problem still exists.

    the problem is that every time i start up x, i have to restore my alsa settings with alsactl restore before i can get any sounds, the volume is on normal and i have kde mixer settings set to load volume on startup, but for some reason this happens. it works fine in text mode with mpg123 before i start x up, but once kde loads, i have to do a su and alsactl restore. its really more of an annoyance than anything else, but i'd like to find out what the problem is and how to fix it

  6. #6
    Senior Member gore's Avatar
    Join Date
    Oct 2002
    Location
    Michigan
    Posts
    7,177
    Heh, well, how are you with funds?

    I'd recommend buying a book from http://store.slackware.com

    The Slackware Essentials book and the Compete Linux reference. I've never seen a problem like yours, what kind of sound card do you have? If you don't have the money too lay out for the books, at least buy a Sound Blaster Live! Sound card, as they are only like 30 dollars, and tend to solve most sound problems.

    This is my Slackware 10 machine:

    HP Pavilion

    Pentium 3 733 MHz

    384 MB RAM

    Sound Blaster Live! Sound Card

    Nvidia Riva TNT2 16 MB Video Card

    43 GB HD (Seriously)

    CD-RW Drive

    DVD - ROM Drive

    A few other things that don't matter.

    This box works on every OS I've put on it. I've never had a sound problem, so you might want too get a Sound Blaster Live ! Card, as they seem to never have a problem with Linux, and Slackware finds it for you, and all you have too do is the Alsamixer and aslactl store commands, and you're done.

    Very good card and works with all OSs I've seen. And very cheap price.

  7. #7
    Senior Member
    Join Date
    Dec 2003
    Posts
    317
    i figured it out: kde was setting my center volume down to zero every time and i didnt realize that center volume was important, i thought that the master volume was all that mattered. i had to go to the mixer settings in kde and save my volumes and set it to load the volumes at startup. i really appreciate your input though

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •