WinXP - Unable to view contents of My Computer or Control Panel
Results 1 to 9 of 9

Thread: WinXP - Unable to view contents of My Computer or Control Panel

  1. #1
    The Doctor Und3ertak3r's Avatar
    Join Date
    Apr 2002
    Posts
    2,743

    WinXP - Unable to view contents of My Computer or Control Panel

    Hi Guy's

    Looking for direction again:

    Have a clients machine Have cleaned up a Naichi infection, and a **** load of parasites (no Coolweb search detected so far)

    The problem is That if I use Windows explorer or the "My Computer" shortcut on the start menu, or The Control Panel Shortcut.. The contents of these 2 folders are Blank. I can access control panel items using the Run command.. and the drive contents are accessable if I use the address/url bar..

    The machine has Norton AntiVirus, and In the registry I Reset the Jscript.dll entry in the registry, also reinstalled ms scripting host.. All that this has managed is to be able to view the contents of the control panel..

    just at a loss for the next direction.. policy?, more registry hacks? another parasite that I have missed?

    thoughts..

    Cheers
    "Consumer technology now exceeds the average persons ability to comprehend how to use it..give up hope of them being able to understand how it works." - Me http://www.cybercrypt.co.nr

  2. #2
    AO übergeek phishphreek's Avatar
    Join Date
    Jan 2002
    Posts
    4,325
    Just to point out the obvious... have you changed the view settings?

    tools, folder options, view,
    View hidden and/or system files?
    Maybe someone/something marked all the files/folders hidden?

    Can you see them in command prompt?

    If not, have you tried

    dir /AH (display hidden?)

    What is the output of the "tree" commmand from root?
    That should give you a clear view of the filesystem...

    That is just off the top of my head...

    Also, under a folder or the filesystem...

    view, and choose details. Make sure all details you want to see are checked off.
    Quitmzilla is a firefox extension that gives you stats on how long you have quit smoking, how much money you\'ve saved, how much you haven\'t smoked and recent milestones. Very helpful for people who quit smoking and used to smoke at their computers... Helps out with the urges.

  3. #3
    The Doctor Und3ertak3r's Avatar
    Join Date
    Apr 2002
    Posts
    2,743
    View setting .. yep no problems..

    I did fail to mention.. if I use the address bar I can view the contents of , say, the C: or the cdrom.. but when I attempt to view the contents of my computer..ie I should see a:\, c:\, CD-ROM, Control Panel etc.... the page is blank.. use the address bare type in c: .. yep there is all folder and files..

    Command promt dir listing work normaly..
    tree command .. works ok..

    the prob is it just the contents of the My computer folder..
    interesting I went into the start menu properties.. and changed the view to show my compuiter as a menu.. there is the contents of my computer.. ..still not if opened in WWindowes explorer..
    "Consumer technology now exceeds the average persons ability to comprehend how to use it..give up hope of them being able to understand how it works." - Me http://www.cybercrypt.co.nr

  4. #4
    AO übergeek phishphreek's Avatar
    Join Date
    Jan 2002
    Posts
    4,325
    I suspect a problem with the user profile? (shortcuts, settings, etc.)

    Create a new user and log in under that new user.

    Still have the problem?

    I'm searching for .reg "tweaks" that would cause this... but so far... I've found none.
    Just some to remove the shortcut or disable access to the drive completely...

    Ah... here we go.

    http://www.winguides.com/registry/display.php/148
    Quitmzilla is a firefox extension that gives you stats on how long you have quit smoking, how much money you\'ve saved, how much you haven\'t smoked and recent milestones. Very helpful for people who quit smoking and used to smoke at their computers... Helps out with the urges.

  5. #5
    The Doctor Und3ertak3r's Avatar
    Join Date
    Apr 2002
    Posts
    2,743
    Thanks Phis..

    Handy link.. unfortunatly.. I may need to have a better look at the Policies of the machine.. or a closer look for Malware..

    Unable to access the User Accounts to create a new account.. tried in safe mode as well.. Not this problem with the display of items in My Computer ..is also in safe mode..

    I am now wondering if this isn't another machine that has a problem after a failed SP2 install..

    I suspect the customer attempted a SP2 install with the virus and Parasites..best precurser to failure
    "Consumer technology now exceeds the average persons ability to comprehend how to use it..give up hope of them being able to understand how it works." - Me http://www.cybercrypt.co.nr

  6. #6
    AO übergeek phishphreek's Avatar
    Join Date
    Jan 2002
    Posts
    4,325
    You can use the system logs, along with the system restore data to get a better idea of what software was installed and when. If it was SP2, you should be able to uninstall it. Hopefully the parasites didn't damage too much?

    At this point... it might have been faster to backup important data and format/reinstall?

    I know when I get stumped... I like figure out and fix the problem. But when it comes to a "client's pc"... I just go for a solution that will be the fastest and they won't need to call me back right away because they found another problem caused by malware.

    I'm out of ideas at the moment... but I haven't had my 8:00 coffee.
    I'll post again if anything pops into mind.
    Quitmzilla is a firefox extension that gives you stats on how long you have quit smoking, how much money you\'ve saved, how much you haven\'t smoked and recent milestones. Very helpful for people who quit smoking and used to smoke at their computers... Helps out with the urges.

  7. #7
    Senior Member
    Join Date
    Jun 2003
    Posts
    723
    My brother had the exact same problem with his laptop, SP2 broke his wireless connection so we uninstalled it, then reinstalled SP2 a month later and it was a just fine for a a while then after the last updates, a week two ago or so. The control panel dissapeared, services would only show on only one of the two settings (tabs at the bottom, extended and ???), add user dissapeared, add and remove programs dissappeared(IIRC)... But really everything else worked just fine no crashes or wonkiness just couldn't see config menus basically ( Thanks Bill for windows's awesome cli ) . He had no spyware or viruses, but he did have problems with norton before as he had it installed previously and it would not let him deinstall it properly. The answer i found is that there is no answer, that i could find anyways...
    Do unto others as you would have them do unto you.
    The international ban against torturing prisoners of war does not necessarily apply to suspects detained in America\'s war on terror, Attorney General John Ashcroft told a Senate oversight committee
    -- true colors revealed, a brown shirt and jackboots

  8. #8
    The Doctor Und3ertak3r's Avatar
    Join Date
    Apr 2002
    Posts
    2,743
    Phish..

    Your help has been appreciated, it has given me a path of investigation..
    And yes your right..it will be quicker to clean install.. repairs are a little quiet.. and I have a day or so to play with this one..

    And Lumpy.. i suspect that norton is a contributing factor.. changing a NAV modified key involving jscript.dll (mentioned earlier), that returned vision to the control panel folder..

    Thanks for the help sofar.. will post the final verdict (decision time Oct 27 06:00 UTC- gives me 8.5 hrs)

    Cheers
    "Consumer technology now exceeds the average persons ability to comprehend how to use it..give up hope of them being able to understand how it works." - Me http://www.cybercrypt.co.nr

  9. #9
    The Doctor Und3ertak3r's Avatar
    Join Date
    Apr 2002
    Posts
    2,743
    HAve copied the customers files (documents and settings folders) .. and partitioned and formated the hdd.. in the process of re installing XP.. interesting I copied about 50 files that "looked" suspect from the %System% folder.. in the process of copying detected one as a part of a D/l trojan.. now 24 hrs AVG and Symantec detected 1 more as a trojan... it will be interesting what I find in a weeks time.... can't see what I did wrong to miss these being linked to in the registry.. I did do a Remote registry scan.. from the PE disk... , looking for strange stuff in RUN and anything to do with Explorer.exe. hmm i do have a backup of the registry.. will have to grab some tools and give it a bit of a look.. not profitable. but it could be..

    Cheers
    "Consumer technology now exceeds the average persons ability to comprehend how to use it..give up hope of them being able to understand how it works." - Me http://www.cybercrypt.co.nr

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •