need MORE Knoppix SAM help
Results 1 to 10 of 10

Thread: need MORE Knoppix SAM help

  1. #1
    Member
    Join Date
    Jul 2003
    Posts
    70

    need MORE Knoppix SAM help

    Sorry for starting another topic on this, I know there has already been one but I've waited for over a day with no reply and you guys are usually really quick on getting back with answers. I'd wait longer but it's driving me CRAZY! I can't figure out what I have to mount and where I have to mount it etc. I'm using knoppix STD. I tried "mount /mnt/hda1" It mounts. then I "cd /mnt/hda1" but I can't find the windows file in there. I've tried mounting dev/hda1 to the /mnt/hda1 but it doesn't work right. IS there anway somebody could give me a step by step way of doing this. I'm really new to linux and I'm just messing around trying to crack my own box. And yes I have heard of the man command. It's not helping. Thanks. You guys are great! Should open up ur own consulting firm.

  2. #2
    #su

    #mount -rw /dev/hda1 /mnt/hda1

    #mount -rw /dev/sda1 /mnt/sda1

    #cd /mnt/hda1/windows (or /mnt/hda1/winnt)

    #cd system32

    #cp sam /mnt/sda1

    #cp system /mnt/sda1

    #umount /dev/sda1

    #shutdown -h now
    the above only works if your windows installation is on the first (hda) harddisk of your system, and on the first partition (hd*1) . if it is on the second harddisk chances are you need hdb1 or if it is in another partition you might need hda3 instead of hda1.

    you can see this pretty easily when looking at your desktop with a normal knoppix version, knoppix std doesn't show these automounts (perhaps it doesn't even automount), but you can also run the following command:

    #dmesg | grep "hda"

    and read what the output there is.

    hope this helps

  3. #3
    Member
    Join Date
    Jul 2003
    Posts
    70
    that almost works. I mount the harddrive (it happens to be hda2, took me a while to figure THAT out) but when I try to mount /dev/sda1 /mnt/sda1 it says "mount point /mnt/sda1 does not exist. Thanks for help.

  4. #4
    oh, then you first need to create the mount point:

    #mkdir /mnt/sda1


    that should do it

  5. #5
    Member
    Join Date
    Jul 2003
    Posts
    70
    Ok I made that that directory and I checked to make sure it was there. It was, but then is says /dev/sda1 is not a valid block device. I'm guessing that this isn't the usb drive? Thanks for ur help lepricaun.

  6. #6
    then it probably is:

    #mount -rw /dev/sdb1

    or

    #mount -rw /dev/sdc1

  7. #7
    Member
    Join Date
    Jul 2003
    Posts
    70
    No, that wasn't it either. I found something on another site that said I had to "modprobe usb-storage" I guess that makes the computer look for it? Anybody know more on this? Thanks

  8. #8
    if you are using knoppix std then it would automatically look for USB storage. but perhaps you have a chipset of which KNOPPIX does not have the USB drivers for...

  9. #9
    Member
    Join Date
    Feb 2002
    Posts
    84
    If you don't want to use the man then try

    #mount --help

    You didn't tell us what kind of filesystem you wanted to mount NTFS or FAT
    to mount a windows FAT filesystem try this:

    #mkdir /mnt/windows

    #mount -t vfat /dev/hda1 /mnt/windows

    #cd /mnt/windows

    #ls

    and voila there's your windows partition.
    [shadow]OpenGL rules the game[/shadow]http://www.AntiOnline.com/sig.php?imageid=499

  10. #10
    Junior Member
    Join Date
    Sep 2004
    Posts
    13
    This what I do and it's never failed to copy them to the flash drive succesfully -

    open shell
    su
    mount /mnt/sda1
    mount /mnt/hda1
    cd /mnt/hda1
    cd windows(or winnt)
    cd system32
    cd config
    ls (to double check the SAM and system files are there)
    cp SAM /mnt/sda1
    cp system /mnt/sda1
    umount /mnt/sda1
    exit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 Security News

     Patches

       Security Trends

         How-To

           Buying Guides