slackware nvidia drivers
Results 1 to 7 of 7

Thread: slackware nvidia drivers

  1. #1
    Senior Member
    Join Date
    Dec 2003
    Posts
    317

    slackware nvidia drivers

    i just got a new nvidia fx 5600 256 mb graphics card and i'm trying to use it with my computer, running slackware 10. the nvidia readme out at www.nvidia.com/linux, which is also where i got the drivers, says the only thing you have to do is install the drivers and edit xorg.conf to use "nvidia" instead of "nv" as the driver and make sure that the glx module loads and that the dri and glcore modules dont load. i did all that (i didnt even have anything about a glcore moduel in my xorg.conf) and now when i try to start x, i get a black screen and i have to shut my computer down hard(i cant ctrl+alt+f6 back to console). the card worked well in windows and functions using the generic nvidia drivers on slackware, but i'd like to use the latest drivers from nvidia. can anybody help me?

  2. #2
    Leftie Linux Lover the_JinX's Avatar
    Join Date
    Nov 2001
    Location
    Beverwijk Netherlands
    Posts
    2,535
    First try to see if there is information in the /var/log/Xorg.0.log (or Xorg.8.log can't remember)

    After installing the drivers (ugly curses wizzard) have you tried xorgsetup (another ugly curses wizzard) that should do all the basic X configing you'll need..

    After that you can add stuff like scroll-mouse and stuff ( shameless plug to one of my sites http://jinx.etv.cx/tut/index.php?url=xconfig.bbc )
    ASCII stupid question, get a stupid ANSI.
    When in Russia, pet a PETSCII.

    Get your ass over to SLAYRadio the best station for C64 Remixes !

  3. #3
    Senior Member
    Join Date
    Dec 2003
    Posts
    317
    i configured it using xorgconfig and then made adjustments for the mouse, etc. directly to xorg.conf... when i try to run xorgsetup, it says that only root can setup X, so i did a su and it says that it cant find xorgsetup when i try to run it as root, even if im in the folder that contains xorgsetup. according to that readme, all i should have to do is change the graphics card driver from "nv" to "nvida" and check on those modules and it should work. ill post my xorg.0.log file and my xorg.conf in a sec

  4. #4
    Senior Member
    Join Date
    Dec 2003
    Posts
    317
    well, there are a couple things:
    1. i did cat /var/log/Xorg.0.log | grep "EE" because all errors are marked with EE and i got one error: "glx failed to initialize: could not find nvidia driver" which is wierd cuz the nvidia driver installation seemed to go fine

    2. my xorg.conf file has two driver settings in the graphics card section:
    #The Driver line must be present. When using run-time loadable driver
    #modules, this line instructs the server to load the specified driver
    #module. Even when not using lodalble driver, modules this line
    #indicates which driver should interpret the information in this section.

    Driver "vga"
    and

    Section "Device"
    Identifier "**NVIDIA (generic) [nv]"
    Driver "nv"
    #VideoRam 262144
    # Insert Clocks lines here if appropriate
    endsection
    i've been changing the second part to nvidia cuz that's what the readme on nvidia.com said to do, what is the relevance of that other driver that's loading?

  5. #5
    AO Antique pwaring's Avatar
    Join Date
    Aug 2001
    Posts
    1,409
    Although it's for Gentoo and not Slackware, this guide shows you how to configure your xorg.conf file for the nVidia drivers:

    http://www.gentoo.org/doc/en/nvidia-guide.xml
    Paul Waring - Web site design and development.

  6. #6
    Leftie Linux Lover the_JinX's Avatar
    Join Date
    Nov 2001
    Location
    Beverwijk Netherlands
    Posts
    2,535

    xorg.config

    attached is my xorg.conf(.txt for the upload)

    you might want to change some stuff.. like the AGP speed..

    also make sure there is no (residual) XF86Config file left..
    ASCII stupid question, get a stupid ANSI.
    When in Russia, pet a PETSCII.

    Get your ass over to SLAYRadio the best station for C64 Remixes !

  7. #7
    Senior Member
    Join Date
    Nov 2001
    Posts
    1,255
    Originally posted here by Phonedog911
    well, there are a couple things:
    1. i did cat /var/log/Xorg.0.log | grep "EE" because all errors are marked with EE and i got one error: "glx failed to initialize: could not find nvidia driver" which is wierd cuz the nvidia driver installation seemed to go fine
    Two things:
    1. You don't need to pipe cat to grep, grep accepts filenames as the last argument.
    2. This isn't an x.org problem, or a slackware problem. If it can't find the nvidia driver, you haven't loaded the module the installer built for you. Su to root, and do modprobe nvidia. Add that line as the last line to /etc/rc.d/rc.modules and you should be set. You can confirm it's loaded before running X by using lsmod.
    Chris Shepherd
    The Nelson-Shepherd cutoff: The point at which you realise someone is an idiot while trying to help them.
    \"Well as far as the spelling, I speak fluently both your native languages. Do you even can try spell mine ?\" -- Failed Insult
    Is your whole family retarded, or did they just catch it from you?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •