firewall is blocking telnet
Results 1 to 3 of 3

Thread: firewall is blocking telnet

  1. #1
    Senior Member
    Join Date
    Oct 2004
    Posts
    118

    firewall is blocking telnet

    I stay on a campus with all the computers connected to the internet through a proxy server running http and ftp services on port 3128. For a while now, I've been trying to telnet to a system outside the network but it just isn't working. Now, i know that some people have used tunneling and could connect. But I just can't seem to be able to do it. I've tried desproxy, but it isn't working. I can telnet to any of the servers set up within the campus but not outside. I don't think i'll be able to ask the Administrator(s) to open a port for me because there is too much bureaucracy involved. Is there any way to configure telnet to use the proxy server? There is another thread devoted to the same topic, but it's been closed. Can anyone help me out? I'm using http-tunnel for kazaa. Can I use the same thing with telnet?
    Never trouble another for what you can do for yourself.
    -Thomas Jefferson

    http://www.AntiOnline.com/sig.php?imageid=777
    Share on Google+

  2. #2
    Right turn Clyde Nokia's Avatar
    Join Date
    Aug 2003
    Location
    Button Moon
    Posts
    1,696
    Why do you want to telnet out? Where are you trying to connect to? - It may be best to fill in the gaps before some self righteous idiot neggs ya!
    Drugs have taught an entire generation of kids the metric system.

    http://tazforum.**********.com/
    Share on Google+

  3. #3
    Hi mom!
    Join Date
    Aug 2001
    Posts
    1,103

    Telnet bad, bad, BAD! Use SSH instead

    Telnet is an unsafe application - it sends all your data (like passwords, keystrokes, -everything- ) unencrypted over your network, which makes it very easy for someone to log everything you do. In other words: 'su' one time, and loose your box.

    Instead of telnet, use SSH (protocol 2 is safer than protocol 1). If you are lucky, you might find that the administrators of your network disabled telnet because of its unsafe nature, but did not disable SSH, to provide an safe alternative to telnet (SSH uses another port than telnet).

    In any way, if you are connecting to a machine you can configure, it's usually quite easy to configure the SSH daemon to listen on a non-default port. Check the man-pages of your distribution for sshd.

    Doing a quick google for 'tunnel ssh' resulted in quite a few hits, so if you're unable or unprivileged to reconfigure the box, you'll probably find something there. Good luck!

    On a side-note: don't pay much attention to nickpickers here that either flame you or assign negative antipoints for questions like these. Your question is valid and well constructed, even if it expresses little knowledge of computer-security. Apparently some users here expect all others to be computer geniusses. They tend to forget that everyone was a beginner once, and that there is no such thing as a stupid question.
    I wish to express my gratitude to the people of Italy. Thank you for inventing pizza.
    Share on Google+

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •