LG CDROM Firmware Update.. Help please!
Results 1 to 8 of 8

Thread: LG CDROM Firmware Update.. Help please!

  1. #1

    Question LG CDROM Firmware Update.. Help please!

    Hey guys, I just recently ditched Windows XP Professional for Windows 2000 Professional. However, I've run into a problem that I didn't have when updating my drivers in XP...

    I have LG-8080B CD-ROM. I've been to the LG website, and the download that I transfer to a floppy disk doesn't work. I also tried several CDROM Firmware forums and I keep running into dead-ends when I download them and try to update.

    I was wondering if any of you have had this problem before.. In my experience, updating the LG drivers have been most difficult.

    I need to update the firmware or driver because of several errors that I encounter with different CDROMs. One of the CDs there was an issue with the burning of earlier versions, which is what I have. And I'm fairly certain that that particular CD is causing it's own error. But with another CDROM, I get very slow system speeds and problems when trying to open the CD.

    Then again, every other CD or CDROM I've used or needed to install had no problems at all.

    Anyway, please.. Help me find out what I'm doing wrong with the driver update. If you need any additional information, please let me know what I need to add.

    Thanks a ton!


  2. #2


    By the way, I'd like to mention that I have had this issue once before, and I tried looking at the driver websites that I was referred to before, but I can't seem to figure out what I'm doing wrong this time. I'll continue looking in the meantime, but if any of you have had this issue before, or might know what to do, please help, thanks again^^


  3. #3
    I've tried downloading several drivers from driverguide.com, but stopped until I get some more info. I did the Windows Update, but it didn't have any updates for my CDROM.

  4. #4

    More Info.

    I also went to LG's website and selected support >>> downloads >>> software >>> CD-RW >>> Page 2 >>> 8080B >>> Downloaded..

    The file I then saved to A: but when I restarted, it said NTLDR not available. I can't seem to get into the dos to install the update. The other types of files I tried (I backed up the original one) I had to just put in System32/Drivers/CDROM.SYS but they didn't work, and actually I think messed it up more. What do I do! Thanks guys.


  5. #5
    Right turn Clyde Nokia's Avatar
    Join Date
    Aug 2003
    Button Moon
    If your having problems actually opening the CD tray, it may not be a driver/firmware problem but an actual physical prblem with the drive itself.

    As you said you have not had any probs with cdroms in the past - i am taking it you mean with this machine?

    Genrally you dont need drivers for a cd-rom and only need a firmware update if you are having problems such as recognising disc's etc.

    I would check you have the jumper settings set corect (either Master or slave) and check the power connector is inserted properly. If you still have problems with it you may want to consider buying a new one.

    They go for around 30 ish here - LG have a reputation for making cheap cd-roms atleast over here they do, (in my opinion anyway) Maybe you could buy a diferent brand?
    Drugs have taught an entire generation of kids the metric system.


  6. #6

    Exclamation LG Quality

    In general, I agree with the opinion of your country. I've had a cellphone made by LG, as well as several computer components. I've had issues with all of them.. It seems like they're trying to improve their image, and I've seen them come out with HDTV now.. I don't think I'd ever spend thousands of dollars on an LG product^^ I admit, it's about time I get a new ROM drive. This is CD-RW, and I've been wanting a nice DVD-RW for a while now. But I'm a broke college student at the moment.

    Does the NTLDR error message when I start up my system with a floppy in A: have anything to do with my having issues updating my firmware?

  7. #7
    They call me the Hunted foxyloxley's Avatar
    Join Date
    Nov 2003
    3rd Rock from Sun
    Does the NTLDR error message when I start up my system with a floppy in A: have anything to do with my having issues updating my firmware?
    I think it means that you have the A drive enabled in your boot order, before it gets to your C drive, and as there isn't anything on it to boot from, it flags up the 'no ntldr' message.

    Take the floppy out of the A drive until the PC has finished loading, Then try to load the drivers.
    55 - I'm fiftyfeckinfive and STILL no wiser,
    OLDER yes
    Beware of Geeks bearing GIF's
    come and waste the day :P at The Taz Zone

  8. #8
    I used an old startup disk to get dos to run, and was able to upload the firmware successfully.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts