Un-able to write to ext HD using Knoppix 3.7
Results 1 to 6 of 6

Thread: Un-able to write to ext HD using Knoppix 3.7

  1. #1
    Junior Member
    Join Date
    Mar 2005

    Un-able to write to ext HD using Knoppix 3.7

    I have an external hard disk that plugs into a USB 2.0 port. I decided to see if the ext HD is also recognised under Knoppix 3.7. It is, the thing is though, I am not able to write files to the hd.
    I have used the command mount /mnt/sdb5(name of ext hd) and next to writeable it says yes, but yet, I am unable to copy or write files to the hard disk.

    Would anyone have any tips or advice on this problem?


  2. #2
    Senior Member
    Join Date
    May 2003
    what does it say when you try?
    Everyone is going to die, I am just as good of a reason as any.


  3. #3
    Senior Member nihil's Avatar
    Join Date
    Jul 2003
    United Kingdom: Bridlington
    Hi, and welcome to AO,

    You say that the HDD is "recognised", what do you mean by that? what I am saying is can you read files but not write them? and can you write them in the opposite direction (from the external drive)?


  4. #4
    Senior Member
    Join Date
    Oct 2003
    As I know Koppix not supporting NTFS(windows xp, windows 2000 and windows servers) for writing but can read files from it.
    FAT32 and Linux partition types are supported for writing.

    Correct me if i am wrong.
    // too far away outside of limit

  5. #5
    Junior Member
    Join Date
    Mar 2005
    Sorry for my late reply. I currently don't have internet access from home you see.
    The message that I get when I want to copy a file, say from a partition of my internal hard disk called TEXT to my external hard disk is - cp: cannot create regular file 'mnt/sda5/TEXT': read only file system.
    Now it says that the ext hard disk(sd5) is writable and I did moutn /dev/sda5 and it didn't give me any message.
    However, yes, the ext hard disk is NTFS formatted. So if MrBabis is correct, then I may be unable to write to the ext hard disk unless I change to FAT32.

  6. #6
    Senior Member
    Join Date
    Mar 2005


    In the past, Linux could only read NTFS partitions but that changed with Knoppix 3.4.
    Knoppix 3.4 uses the NTFS drivers that are included with Windows, but there is a catch.

    You must use a Knoppix program called Captive NTFS. It has a wizard that helps configure your system.
    To find Captive NTFS, Click the "K" menu, then KNOPPIX, UTILITIES, CAPTIVE NTFS.

    When Captive NTFS is run, it scans your computer drives for the included NTFS drivers it needs.
    You will have to click "Forward" to see the list of system file, then click "Forward" again so the wizard mounts and scans your harddrive for the files it needs. It can even scan for the files off your inserted USB stick. Captive NTFS will recommend downloading the latest version of NTFS drivers from the MS site or an XP SP1 CD.

    I think the standard (not updated) drivers will work only for reading the needed files.

    Once you are ready to mount an NTFS partition, do not mount it from the desktop because the standard Linux Kernel NTFS module is used, not Captive NTFS. If you've mounted it, unmount it.

    Open a terminal and mount the drive manually using this command (between the quotes):
    (Replace the /hda1 with the correct name of your partition)

    Command to mount:
    knoppix@ttyp0[knoppix]$ "sudo mount -t captive-ntfs -o uid=knoppix,gid=knoppix /dev/hda1 /mnt/hda1"

    -T = filesystem type
    -O = passes some other general options to mount procedure, specifically username and group.

    I suggest you mount the drive at /mnt/hda1, cause this directory is Knoppix created at boot time. The drive should now be writeable.

    Once you are finished, unmount it to ensure that any changes are sync'd. This is important to remove the cached RAM data to the drive.

    Command to unmount:
    knoppix@ttyp0[knoppix]$ "sudo umount /mnt/hda1"

    The write speed is pretty slow though.
    Beta tester of "0"s and "1"s"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts