Win XP PRO acces denied error won't allow access to files on d: drv.
Results 1 to 7 of 7

Thread: Win XP PRO acces denied error won't allow access to files on d: drv.

  1. #1
    Junior Member
    Join Date
    Feb 2005
    Posts
    5

    Win XP PRO acces denied error won't allow access to files on d: drv.

    Hello All.

    I been having trouble getting access to the files on my multi-drive win xp pro system. The system has 4 250gb maxtor drives. The main drive is divided into 3 partitions.

    1. for the os
    2. for recovery
    3. for data

    The other drives are for storage.

    It appears that all drives are functioning correctly on all drives except D: and all files and folder on D:\.

    I had to re-install xp on this system. Before the re-install all drives were accessable normally.

    I have tried changing the sharing options on this drive but things are still acting the same. (access denied on D

    I even changed myself to the owner of these files in SAFE MODE on both my account and the administrator account. I think i'm the owner of the drive as well.

    In SAFE MODE on the security tab I checked the box for full control. No services appear to denied.

    Can someone tell me where & how to access the SID on winxp?

    Any help is greatly appreciated.

  2. #2
    Member
    Join Date
    Apr 2005
    Posts
    97
    Would that drive D be a partition of the first hard drive? If my reading is correct, your first hard drive is configured to be C, D and E given the three (3) partitions. If yes, then the problem is on accessing the partition (it may have been tampered by the reinstallation of the XP platform; not really sure). In that case, partition recovery maybe needed although I have no immediate idea as of now on how to do it.

    If drive D is a physical drive by itself, then you may need to reconfigure the CMOS to identify the master drive and the slaves (three slaves as you said you had 4 physical drives). BTW, you've got a terabyte there with four 250GB... wow!
    Si vis pacem, para bellum!

  3. #3
    Senior Member nihil's Avatar
    Join Date
    Jul 2003
    Location
    United Kingdom: Bridlington
    Posts
    17,190
    Can someone tell me where & how to access the SID on winxp?
    Why, what do you propose to do?

    Have you checked that the drive is both recognised by your BIOS and Windows and has the right size and other attributes?

    What exactly do you nean by "access denied"? do you mean you cannot get into the drive at all, or that it won't let you open the files and folders.

    First thing I would try is running the Windows repair option................incidentally, why did you have to reinstall it?

    Then try creating a completely new user account with admin rights and see if you can grant them authority.

    Cheers

    By the way, are these SATA drives?

  4. #4
    Senior Member
    Join Date
    Oct 2002
    Posts
    1,130
    I have had problems similar to this. I will explain my problem and you can see if it helps.

    I had to reinstall a copy of Windows XP, however, at the time, there was no way to perform a proper backup of all the user data, which was located in "C:\Documnts and Settings\User". So rather than wiping the hard drive out and starting from scratch, the new OS was simply onstalled directly on top of the last one. Upon booting up the new OS, "C:\Documents and Settings\User" was inaccesible, dispite the fact that I had created a "user" account during the new installation.

    I think this is due to ownership problems with the folder. The old "User" folder was owned by an administrator, who no longer existed on this system. When the new administrator tries to access it, his SID does not match that of the owner of the old "User" folder.

    I solved this problem by booting the system with a Live CD known as Knoppix. This is an entire operating system which fits on a CD. This way I was able to bypass file and folder security on NTFS. The contents of the "User" directory were then copied to a FAT32 drive, and when the new OS was booted again, they were copied back to their proper location. This can be done much in the same way that Windows Explorer manages files, just drag and drop. You will need a FAT32 partition or enough removable storage to accomplish this, as Linux cannot currently write to NTFS partitions safely.

    I think this may be your problem.
    Government is like fire - a handy servant, but a dangerous master - George Washington
    Government is not reason, it is not eloquence - it is force. - George Washington.

    Join the UnError community!

  5. #5
    Junior Member
    Join Date
    Feb 2005
    Posts
    5
    Hello.

    Yes you are correct Goitz.

    The d: drive is a partition on the Primary master (c:,d:,e. I also have a primary slave 250gb.

    The other two 250's are on a silicon image raid controler card as a master slave configuration.


    nihil I was told that sometimes when you re-install xp pro the SID for the old installation doesn't match the new one so you are sometimes denied access to drives.

    I guess SID stands for system id. I don't know.

    Thanks for any help.

  6. #6
    Senior Member nihil's Avatar
    Join Date
    Jul 2003
    Location
    United Kingdom: Bridlington
    Posts
    17,190
    Hi 3595lover

    Hmmmmmmmmm, sounds a bit familiar, which is why I questioned your wanting to know where the SID was

    The SID is the Security IDentifier, and is a datastructure.

    What I think has happened is that you destroyed the old SID and generated a new one when you re-installed. That is what happens, it is normal.

    The new SID is different, so although you recreated your Admin and user account, these are different and would not be able to access files that were owned under the old SID accounts. (The system uses the SID not the account name)

    I hope that you have not used the Microsoft EFS encryption on these folders, as you need the old SID to open them, unless you fancy your chances at cracking 128 bit encryption

    OK, next step:

    1. Go into something like folder properties, view and uncheck the box that says "use simple file sharing"

    2. Go in using the full administrator password and take ownership of the folders. See if you can get into them that way.

    If that doesn't work try using the attached tool

    At the run prompt give it:

    c:\{folder}\takeown.exe D:\folder\................etc.

    Copy the contents into a new folder and delete the original (after you have checked the new one of course )

    Good luck

  7. #7
    Junior Member
    Join Date
    Feb 2005
    Posts
    5
    Hello everyone.

    I tried just about all the suggestions that you all gave me. I really appreciate it. Unfortunately none of them worked for me. But, I was given a solution by a user on another forum.

    I would however like to know more about this problem & the SID. So any added info is welcome.

    Here's the solution I was given.

    . Download and install subinacl from:

    http://www.microsoft.com/downloads/d...displaylang=en

    . Start, Run, CMD
    c:
    cd\
    cd "C:\Program Files\Windows Resource Kits\Tools"
    subinacl /subdirectories D: /grant=administrators=f
    subinacl /subdirectories D: /grant=system=f

    It appears to have done the trick. I don't know what it did but it did it. This is a tool I will keep with me at all times.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •