Promiscuous mode and Centrino laptop in XP
Results 1 to 9 of 9

Thread: Promiscuous mode and Centrino laptop in XP

  1. #1
    King Tutorial-ankhamun
    Join Date
    Jul 2004
    Posts
    897

    Promiscuous mode and Centrino laptop in XP

    Has anyone had any luck getting the Intel Pro Wireless 2200 (802.11G) into promiscuous mode under Windows XP? I've got the newest drivers from Intel and the newest WinPcap but it still does not seem to work. In Linux it all works fine, but I want to use Cain in Windows for a few functions. So far my Google searches have not turned up much.

  2. #2
    AO Senior Cow-beller
    Moderator
    zencoder's Avatar
    Join Date
    Dec 2004
    Location
    Mountain standard tribe.
    Posts
    1,177
    Negative. Tried several winpcap versions, no go. Time for debian...
    "Data is not necessarily information. Information does not necessarily lead to knowledge. And knowledge is not always sufficient to discover truth and breed wisdom." --Spaf
    Anyone who is capable of getting themselves made president should on no account be allowed to do the job. --Douglas Adams (1952-2001)
    "...people find it far easier to forgive others for being wrong than being right." - Albus Percival Wulfric Brian Dumbledore

  3. #3
    King Tutorial-ankhamun
    Join Date
    Jul 2004
    Posts
    897
    I tried a bit more and it seems I was wrong about it working in Linux, no promiscuous mode there either as best as I can tell.

  4. #4
    Senior Member Falcon21's Avatar
    Join Date
    Dec 2002
    Location
    Singapore
    Posts
    252
    My laptop has intel pro 2100 and promiscuous mode in ethereal and other sniffer tools won't work also...maybe it don't support?

  5. #5
    King Tutorial-ankhamun
    Join Date
    Jul 2004
    Posts
    897
    I thought they got it working in the older 2100 drivers.

  6. #6
    Senior Member
    Join Date
    Aug 2001
    Location
    Calgary, AB Canada
    Posts
    140
    I remember asking this question a while back... Basically, something about them not supporting Centrino wireless yet. I'm not sure why it doesn't work, maybe it has something to do with it being so intigrated? <<sigh>> At least I got the wireless to work with WPA last year. (Using SuSE 9.2 and now 9.3 Professional, it's almost flawless!) Still, no sniffing...

    Just my quick 2 Canadian pennies, and if it wasn't for our damn government issues, they would still be worth more...

    hehe, take care,


    Dave
    Alcohol & calculus don't mix. Never drink & derive.

  7. #7
    Senior Member
    Join Date
    Jul 2004
    Posts
    469
    I have a feeling that what you're really trying to accomplish it to get the card in rfmon mode. Promiscious will allow you to see packets not destined for your IP, but are still belonging to a network that you're attached to. RFMon is where you can sniff any RF packet that is in the air. From my experience the only cards that have this ability are the Orinoco card, some Cisco cards, and cards that use the Prism2/2.5/3 Chipset. Its more or less a firmware limitation of some cards where they do not pass packets to the OS that are coming from a network they're not attached to. In some cases a specialized drive can be used to get this to work but this is mostly with Prism chipset cards. I would try to find out what chipset your card uses and that might lead you to whether it can even enter RFMon mode.

  8. #8
    King Tutorial-ankhamun
    Join Date
    Jul 2004
    Posts
    897
    No, I mean Promiscious mode. RF would be nice, but all I need for Cain is Promiscious and even that does not seem to be supported with 2200.

  9. #9
    Senior Member kr5kernel's Avatar
    Join Date
    Mar 2004
    Posts
    347
    There is a module for ipw2100 that can be compiled in the kernel (at leats in 2.6.11) to enable promiscuous mode.
    kr5kernel
    (kr5kernel at hotmail dot com)
    Linux: Making Penguins Cool Since 1994.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •