Results 1 to 2 of 2

Thread: problems with mysql and slackware 10.1

  1. #1
    Blast From the Past
    Join Date
    Jan 2003

    problems with mysql and slackware 10.1

    hello all

    im moving my small website from my xp home machine to a slackware server i made a few nights ago

    apache works
    php works
    mysql, no idea

    the server is running.. but when ever i try to pass a command to it i get an error

    hexadecimal@hexnet-server:~$ mysqladmin creat phpbb2
    mysqladmin: connect to server at 'localhost' failed
    error: access denied for user: root@localhost (using password: NO)

    tired it as root... same error
    went super user as mysql... 'su mysql'
    still same error

    i followed instruction as i was told....
    mysql_install_db <-- told to run that script

    that script in turn told me to type
    mysqladmin -u root -h hexnet-server password '*****'

    i dont know what i did wrong during the process... kinda tired last night when i was working with it

    is there a way i can start over?


    ps. i would tell you the version and build exactly but i cant run that command without that error message... so its whatever version came with slackware 10.1
    work it harder, make it better, do it faster, makes us stronger

  2. #2
    Elite Hacker
    Join Date
    Mar 2003
    you have to tell it you want to use a password, and it doesn't matter what user you run the command as, the user they're talking about is what you put after the -u option. I think you want to do this:
    mysqladmin -u root -p creat phpbb2
    then it will prompt for the password you made. I hope that works. I'm not too sure of the syntax. If that doesn't work try this:
    mysql -u root -p
    then type your password, then at the prompt type:
    create database phpbb2;
    then you can quit and it should have worked.

    you may have to use -h hexnet-server.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts