Slackware 10.1 Wireless DHCP help
Results 1 to 3 of 3

Thread: Slackware 10.1 Wireless DHCP help

  1. #1
    Join Date
    Oct 2002

    Question Slackware 10.1 Wireless DHCP help

    Hey everybody, i need a little help with Slackware. I bought a Gigafast WF741-UIc USB 802.11b card a little while back, and i've been strugglin to get this sucker working for a little while now. It works perfectly in windows (go figure) but i always enjoy a challenge. I've checked around on the net and this is really a humdinger. The card in question is supported for linux, and i compiled the wlanng (not sure which version, they renamed the folder to something different. it may be pre10 but the changlog says 0.2.0 before pre10, i'd upgrade but i'm trying to get it working with what they provided) driver per the instructions, i've gotten it to accept firmware, the light blinks on it kind of like its sending out beacons, lsmod is showing the driver as loaded, and the autojoin command gives me success but i'm not pulling an address from my router. I looked around and i found out that i need to edit the /etc/rc.d/rc.inet1 file, but i have zero experience and i dont feel like breaking anything. I've had some C++ experience but i have no idea where to even begin. I also took a look at /etc/rc.d/rc.inet.conf and it kind of looks like i can just add a line for wlan0 but i'm not positive on this one. So basically my question is, is there an easy way, or can anyone help me set up DHCP on this card? I've tried Kwifi, and it shows the proper channel, and it shows the proper SSID but i can't get a lease to save my life. Any tips, tricks or suggestions? And switching distros isn't an option. A little side note on the actual computer i'm running this on. Its a Compaq Prosignia 165 laptop, its got a 366 P2 processor, 128MB RAM.

    and if this thread would be better in the hardware forum, if you could move it that would rule.

    Thanks in advance guys,

  2. #2
    Senior Member
    Join Date
    Oct 2002
    Well I'm not running Slackware right now, but I usually do...

    You're right about the rc.inet1.conf file. Open up that file, somewhere in there you should find an entry for the interface you are trying to configure. In most cases this is "eth0" or "eth1" ot something similar. Now, under that section there should be a line that says USE_DHCP="no" or something similar. Simply change that no to a yes and the startup scripts should get a dhcp lease for you. I am unsure if this option is case sensitive.

    I doubt this has anything to do with your hardware. If the hardware drivers are loaded and working correctly, whis is simply a matter of sending out the proper DHCP requests. If you are not sure that these requests are being sent properly, fire up a packet sniffer (tcpdump will do in a pinch) and check for the presence of DHCP_REQUEST, DHCP_ACK, and similar packets. You should see what looks like a normal negotiation for a dhcp lease.

    If, after changing that no to a yes, these packets are not being sent, then there is indeed likely a hardware driver not loaded or something similar. However, I think your problem is in a configuration file somewhere. Take a look at /etc/rc.d/rc.inet1.conf and change it if necessary. Post the results here and someone will try to help you out further if you still need help.
    Government is like fire - a handy servant, but a dangerous master - George Washington
    Government is not reason, it is not eloquence - it is force. - George Washington.

    Join the UnError community!

  3. #3
    Join Date
    Jun 2005
    Maybe this will help. I have found that many different flavors of Linux have trouble with wireless. One thing that worked for me is to set the default gateway manually so it could find the DHCP server.

    route add default gw <interface> <ipaddress of gw>
    ifconfig <interface> down
    ifconfig <interface> down

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts