USB problems ........
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: USB problems ........

  1. #1
    Junior Member
    Join Date
    Jul 2005
    Posts
    5

    USB problems ........

    I didn't mean to but I erased the filesystem off my USB drive and now I can't save files, mount , or reformat it to do any of the above ....... please I am new and I would like to be able to save files to it.


    Great thanks for any help!

  2. #2
    Senior Member
    Join Date
    May 2003
    Posts
    1,199
    formatting the drive is what creats the file system. if you cant even do that, then you had to have physicly damaged the drive.
    Everyone is going to die, I am just as good of a reason as any.

    http://think-smarter.blogspot.com

  3. #3
    AFLAAACKKK!!
    Join Date
    Apr 2004
    Posts
    1,065
    Go to My Computer, there should be an icon that it automatically creates, right click it and click format...

    And this really isn't a newbie security question... This belongs in hardware...
    I am the uber duck!!1
    Proxy Tools

  4. #4
    Super Moderator: GMT Zone nihil's Avatar
    Join Date
    Jul 2003
    Location
    United Kingdom: Bridlington
    Posts
    17,192
    XTC46 may have it there................if you pulled it out without "dismounting" it first this can happen.

    With the device physically detached, look in your hardware and see if the device is listed. If it is just uninstall it, reboot and plug it in again. Try the same with the device attached if that does not work.

    Incidentally, some information on your OPERATING SYSTEM and hardware would help us to help you
    If you cannot do someone any good: don't do them any harm....
    As long as you did this to one of these, the least of my little ones............you did it unto Me.
    What profiteth a man if he gains the entire World at the expense of his immortal soul?

  5. #5
    Junior Member
    Join Date
    Jul 2005
    Posts
    5
    While i forgot to say i erased the filesystem image ( instead of reformat ). Now when I use qtparted I use qtparted it freezes on the progress bar and then crashes. I then tried mkfs but it gives me ..............

    mke2fs 1.38-WIP (09-May-2005)
    mkfs.ext2: No such device or address while trying to determine filesystem size

    Running Kanotix Linux.

  6. #6
    AO Curmudgeon rcgreen's Avatar
    Join Date
    Nov 2001
    Posts
    2,716
    what is this, an external hard drive, or a memory stick or what?
    I came in to the world with nothing. I still have most of it.

  7. #7
    Junior Member
    Join Date
    Jul 2005
    Posts
    5
    I'm sorry for before I was in a hurry .......... but it is a PNY USB flash drive.

    The Duck I tried in windows to reformat but it says I can't reformat the drive because it is not there.

    Thanks for your help so far yall.

  8. #8
    Leftie Linux Lover the_JinX's Avatar
    Join Date
    Nov 2001
    Location
    Beverwijk Netherlands
    Posts
    2,535
    lol.. try fdisk or cfdisk and tell us what's there..

    there might be a lot more info then the above error message in /var/log/messages and /var/log/syslog
    ASCII stupid question, get a stupid ANSI.
    When in Russia, pet a PETSCII.

    Get your ass over to SLAYRadio the best station for C64 Remixes !

  9. #9
    Junior Member
    Join Date
    Jul 2005
    Posts
    5
    When I try using cfdisk or fdisk with sudo it says I can't access the drive ........... but here or what each error I get when I try them .............


    FDISK :
    Unable to open /dev/sda1

    CFDISK :
    FATAL ERROR: Cannot open disk drive
    Press any key to exit cfdisk

    (all this is being done in Kanotix Linux and I tried Windows to repair it)

    This may not help much but in qtparted it says hidden. If you want I will put the information from USBview.


    ???? Could it be the partition table????

  10. #10
    Leftie Linux Lover the_JinX's Avatar
    Join Date
    Nov 2001
    Location
    Beverwijk Netherlands
    Posts
    2,535
    I would think it is the partition..
    FDISK :
    Unable to open /dev/sda1
    Are you trying to open a partition with fdisk ??
    Fdisk expects disks not partitions.. try: fdisk /dev/sda
    That might help
    ASCII stupid question, get a stupid ANSI.
    When in Russia, pet a PETSCII.

    Get your ass over to SLAYRadio the best station for C64 Remixes !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 Security News

     Patches

       Security Trends

         How-To

           Buying Guides