LDAP - Not my new best friend.
Results 1 to 3 of 3

Thread: LDAP - Not my new best friend.

  1. #1
    Member
    Join Date
    May 2002
    Posts
    62

    LDAP - Not my new best friend.

    Hello.

    I'm trying to get openLDAP to build on the latest version of Mandriva Linux. My problem is during configuration it gives me the the following error:

    "configure: error: BDB/HDB: BerkeleyDB not available"

    I went to http://www.sleepycat.com and downloaded the latest and greatest version of Berkeley DB and installed it without a hitch, however it still gives me the same error. I was wondering if someone has recently gone through something like this and knows how to get the configuration script to recognize the installation in '/usr/local/BerkeleyDB.4.3'.

    Eventually I want to get this running with a SQL backend, but when I try to drop the Berkeley DB and install SQL as my DB, it says it can't find my SQL libraries. So, if anyone has any insight, I'd appreciate any input.

    Rasem

  2. #2
    Member
    Join Date
    May 2002
    Posts
    62
    I found a resolution. Using the information found at http://www.openldap.org/faq/index.cg...eley&file=1095 I made a couple changes to accomodate my environment.
    --- My script ---

    env CPPFLAGS="-I/usr/local/BerkeleyDB.4.3/include -I/usr/local/ssl/include/openssl" \
    LDFLAGS="-L/usr/local/lib -L/usr/local/BerkeleyDB.4.3/lib -L/usr/local/ssl/lib -R/usr/local/lib -R/usr/local/BerkeleyDB.4.3/lib -R/usr/local/ssl/lib" \
    LD_LIBRARY_PATH="/usr/local/BerkeleyDB.4.3/lib" \
    ./configure

    --end--

    Oh, and technically I'm using Mandriva Linux, not Mandrake.

    Rasem

  3. #3
    T̙͓̞̣̯ͦͭͅͅȂͧͭͧ̏̈͏̖̖Z̿ ͆̎̄
    Join Date
    Dec 2004
    Posts
    3,171
    Hi rasem,

    Glad we could help ...if only all problems could be solved this fast and easy...!

    Eg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 Security News

     Patches

       Security Trends

         How-To

           Buying Guides