So I was very surprised to get a popup today on my freshly installed Ubuntu system when looking up a word at M-W.com. Especially since the ecru-colored notification bar showed up, telling me Firefox had blocked a popup...

Thankfully, EITPlanet had this article linked...thanks JPM!

Source
Like you, I love Firefox for many reasons, including popup blocking. So over the last few weeks Iíve been surprised to see occasional popups.

It turns out that some clever people figured out that you could launch popups from Flash, getting around the Firefox default settings.

Fortunately, you can get around it:
[list=1][*]Type about:config into the Firefox location bar.[*]Right-click on the page and select New and then Integer.[*]Name it privacy.popups.disable_from_plugins[*]Set the value to 2.[/list=1]

The possible values are:
  • 0: Allow all popups from plugins.
  • 1: Allow popups, but limit them to dom.popup_maximum.
  • 2: Block popups from plugins.
  • 3: Block popups from plugins, even on whitelisted sites.