I just recently built a new computer:
Thermaltake Tsunami Case
450W Power supply
P4 3.6ghz
1gb Corsair DDR2 RAM @ 533mhz
dual hard drives (windows/primary on a 250gb @ 5600rpm, secondary 120gb for storage of media)
ATI X800 XT w/ PCI Express
ASUS p5aD2 motherboard
Windows XP Home

This PC is built to be a powerhouse for today's games (I work with the game industry, so having one is necessary just for gaming). The issue is ever since I built it, this PC has been running extremely slow. The strange part is, it's not technically slow. When the PC is working on a task, it completes it at a speed you'd expect it to. The issue is, it randomly locks up for about 15-20 seconds when trying to open a new window, folder, program etc.

For example, I'm in MS word, I try to open up my computer and it freezes (my mouse still works, windows key, etc....just the swindows frozen) for 15-20 seconds, then resumes as if nothing had happened.

Once it resumes, the speed it opens files or runs processes is normal. I can't pinpoint the issue. The second problem is games. They open at a normal speed, but once IN the game, games often experiece FPS slowdowns or FPS locks for 2 or 3 seconds every time you turn a corner in a shooter, or hit a point where a script is suppose to run. When its not locking up, the games run beautifully. Except it's annoying that if every 10 seconds the pc locks up for 2-3 seconds as if it were experiencing framerate issues.

I'm attempting several things. Most processes are eliminated when I try to run games, etc so that's not an issue.

Any ideas how to make this pc run the right speed are appreciated.

Thank you,