PS/2 Mouse problem. plz read...
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: PS/2 Mouse problem. plz read...

  1. #1

    PS/2 Mouse problem. plz read...

    Hi AO Addicts!

    i hope that you can help me with this one, and i also hope that you dont say get a new motherboard / my hardware is buggered!

    First things first, heres my sys spec:

    Celeron 700mhz

    Dual Boot-
    2 x 20gb HDD
    -Mepis
    -XP

    384mb RAM

    motherboard-
    Aopen MX3S

    Graphics-
    ATi RAGE128 pro AGP / rage fury pro

    F U NEED ANY MORE SPEC OR N MORE DETAiL PLZ ASk!!!!


    THE PROBLEM:

    Almost all the time i turn the computer on, the mouse doesn't work. The PC i am using is an old one which has been put together for me by this computer project (so if i cant sort this out i will take it back! But i'd like to solve this one!)

    i am using a PS/2 mouse. as far as i know, the sys should automaticaly detect the mouse and assign it an irq which is usualy 12. Only sometimes does the mouse get detected.

    After doing a little research on the net trying to solve the problem (using the mumber pad to direct the cursor) i was unable to find anything that could realy help. i checked the irq's and it turns out that irq 12 was being occupied by my graphics card! is this normal? can i change this?

    This problem is realy doing my nut in, pls, any suggestions welcomed...

    Also... i have attached a file with a list of where all the irq's are assigned to. i couldnt be arsed to type them all in, up to you if u download 100% safe as houses!

    i look forward to your infinate wisdom(s)!!!!!!!
    The more you know, the less you understand!

  2. #2
    AOs Resident Troll
    Join Date
    Nov 2003
    Posts
    3,152
    You shouldnt have to worry about IRQs in XP.

    Did you try a different mouse???

    MLF
    How people treat you is their karma- how you react is yours-Wayne Dyer

  3. #3
    They call me the Hunted foxyloxley's Avatar
    Join Date
    Nov 2003
    Location
    3rd Rock from Sun
    Posts
    2,528
    i couldnt be arsed to type them all in
    Neither could you be 'arsed' to use capitals or put down the correct words, just some lazy shorthand ..........

    So why should 'we' be 'arsed' to help ?

    Although it has to be said that trying a different / new mouse would be the first step ..........

    If it STILL has issues 'seeing' the mouse, THEN you check your drivers are up to date ......
    THEN consider using the XP CD to try and repair the OS as it might have some corruption in it .........
    you DID say it is an OLD PC, so we assume it has had the XP since day one ????

    Try to use the 'old' mouse on a different PC, if it does work there, it's your PC at fault ....

    Now you go to the shops and buy yourself a new system, nothing too fancy.......... 2.4GHz AMD / P4 - 512 MB RAM an older 128MB GPX card - a MoBo to suit and maybe a nice new 350W / 400W PSU
    and build it up yourself, using the original box to save some money

    Whilst in the shop, they will probably give you a new mouse as a present for buying the other stuff ...........

    jobs a gud'un
    55 - I'm fiftyfeckinfive and STILL no wiser,
    OLDER yes
    Beware of Geeks bearing GIF's
    come and waste the day :P at The Taz Zone

  4. #4
    Ok MR FOXYLOXLEY...

    The reason why i have this PC is because im a skint student who cant afford to buy a new one! Thus the reason why i am trying to sort this problem out and not buying a USB mouse.

    Secondly, the reason why i am missing capitals is because the keyboard i am using is dodgey and some capitals dont work.

    Thirdly, the reson why i didnt want to type the irq's is because THE kEYBOARD S DODGEY AND i DONT HAVE A MOUSE TO COPY AND PASTE!!!

    Now, MEPSiS = LiNUX, i know irq shouldnt realy matter with xp but i think it is being configured before it reaches the OS as when i boot with LiNUX the mouse still doesnt work. The mouse is tempremental i.e it does work sometimes.

    i cant work out what the prob is, maybe dodgey hardware... Another thing that i thought it could be, is that the processor is to fast for the motherboard?

    s there anyway that i can assign the mouse to a different irq address e.g 3 or 4. One weird thing that i noticed, is that the graphics card is using irq 12, this irq address is normaly for the ps/2 mouse?

    anyways, if you need all the irq addresses put up i will do so, and hopefully i have made things a little clearer.

    The more you know, the less you understand!

  5. #5
    AOs Resident Troll
    Join Date
    Nov 2003
    Posts
    3,152
    Well any changes will have to be made at the BIOS level......there may be some tweaking you

    can do for the AGP resources...depending on your board..reading the board manual may help....or googling your board issues

    Thats about all...best way to see if its the board or the mouse...is to try another mouse....

    If you dont want\cant do that.....then you will just have to live with your Sh#tty hardware


    Too bad so sad...sucks to be you

    MLF

    Edit and if you do take MR FOXYs advice...make sure you get a new keyboard too
    How people treat you is their karma- how you react is yours-Wayne Dyer

  6. #6
    Well,

    Thank you all so much for your advice. i have actualy tried another mouse and it is not that. Will definately try and search on ggogle to change the bios. Have actualy had a play around with the bios to no avail. reckon it must just be faulty hardware.

    Anyway, y do u have to be so cocky in your answers?

    im a normal person asking a normalo question, u 2 have to be rude in your answers and basicaly take the piss.

    if this is all the help you can give, dont bother!
    The more you know, the less you understand!

  7. #7
    AOs Resident Troll
    Join Date
    Nov 2003
    Posts
    3,152
    I am glad you edited your post


    As for being rude.....I told you wthe easiest, quickest cheapest way to troubleshoot your problem....

    Try a different mouse.....

    So did foxy...with some humor at that (I found it funny) and you came back being very rude.

    As for your negging me....bam...heres some back.....

    although I have a feeling mine pack more punch....yours wasnt even read...it was gray

    have a great day

    MLF
    How people treat you is their karma- how you react is yours-Wayne Dyer

  8. #8
    They call me the Hunted foxyloxley's Avatar
    Join Date
    Nov 2003
    Location
    3rd Rock from Sun
    Posts
    2,528
    MY AP assignment : I thought it was a green then saw it was grey and with a cute little wordy thing ..........

    Hey Ho ......

    ANYWAY .......
    you didn't say you had all those other problems, if you HAD, I'd have advised you to start saving and buy new ASAP ............
    your system is NOT too fast for the MoBo - it is just old and abused [not YOU abusing it, just that's what happens to H/W S/W over time]

    Bite the bullet
    start saving

    Even if you DO get a fix for this problem. It will only be a temp until the next part fails ..........

    And I KNOW my negs bite : but not here

    Pax

    [edit]
    if this is all the help you can give, dont bother!
    Some people are harder to help than others

    Just read the PM I've sent, it IS a genuine offer.
    feel free to PM any of the mods as to whether you should / could accept .......
    I'll still be here ................ taking the pi55 [apparently]

    [edit2]
    i DONT HAVE A MOUSE TO COPY AND PASTE!!!
    ctrl C to copy
    ctrl V to paste

    or am I missing something ???


    [edit3]
    Also... i have attached a file with a list of where all the irq's are assigned to
    where ????
    55 - I'm fiftyfeckinfive and STILL no wiser,
    OLDER yes
    Beware of Geeks bearing GIF's
    come and waste the day :P at The Taz Zone

  9. #9
    Senior Member nihil's Avatar
    Join Date
    Jul 2003
    Location
    United Kingdom: Bridlington
    Posts
    17,190
    Konshuss

    Here is a simple test for you. Take your keyboard and mouse and attach them to a machine that is known to work properly. The operating system does not matter, only that it correctly recognises PS/2 devices.

    If they don't work then they are at fault.............if they do work (as I think they will ) this tells you that the PS/2 controller/connectors on your motherboard is knackered

    It is NOT your BIOS........................those problems are almost always YES/NO, it works all the time or never.

    Also, you can forget about IRQ shares, that is a problem with other Windows versions sometimes, but XP handles it automatically. Once again, IRQ share problems are usually YES/NO. Anyway, all you have to do is go into device manager to see if there are any conflicts.



    EDIT: It is probably a simple but delicate welding job on the PS/2 block/motherboard, but I would just take it back if the mouse and keyboard check out OK.

    AND Do not try to run XP on an obsolete system like that. You will get a much better result with Windows 2000. Sure, XP will run, but with nothing like its full potential

  10. #10
    The Doctor Und3ertak3r's Avatar
    Join Date
    Apr 2002
    Posts
    2,743
    Hey,

    Had an interesting problem yesterday....

    A customer brought in her pc.. the Ps2 mouse wasnt working..
    I was about to write off the Mobo when I realised I hadn't disconnected the front panel USB's..
    BINGO.. mouse returned to use

    Now get this.. Why the the MOBo even Booted I dont know... the 5v pin in one of the sockets was firmly shorted to the earth..

    so question.. is the mouse getting its fair share of 5v.. is it possable to test the PSU.. there are more than one 5v supply on a psu.. and one of these is the AT (all time) 5v.. if this sucker is sick mouse and/or keyboard will be giving you bother


    Don't fuxor around with the BIOS if it was working one day and not the next.. dont go here just yet..........
    now just give your IRQ's a dump in the river.. forget them.. let the os take care of it.. stuffing arouynd here will just raise more problems then a long tailed cat in a room full of rocking chairs.


    after you have done this you can also try uninstalling the mouse in device manager (Win9x, 2k/XP) give the box a restart and see what results..

    it is probable that the mobo is fuxored.. but it could more likely be some thing else..

    is because THE kEYBOARD S DODGEY
    your biggest clue.. or is it just a duff kbd? your also saying intermittant.. problem with the mouse.. is the socket mount loose?
    "Consumer technology now exceeds the average persons ability to comprehend how to use it..give up hope of them being able to understand how it works." - Me http://www.cybercrypt.co.nr

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •