HDD not Detected
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: HDD not Detected

  1. #1

    Question HDD not Detected

    I'm having a problem getting an external HDD to get detected right by WinXP Home. Here's the breakdown:

    1) HDD is connected to box via USB 2.0 port, thanks to an IDE-to-USB adapter I'm using. Adapter was first plugged to the HDD, then the power, then the adapter was plugged into the USB port. The hardware is detected automatically and installed successfully.

    2) The HDD never appears under My Computer nor under disc management.

    3) Device manager reports that the devices is working properly.

    4) I think this could be my problem -- I already have numerous IDE devices installed (one DVD writer, one CD-ROM, 2 HDDs (one slaved to the other), floppy drive, and zip drive. I've read that perhaps there's something special I have to configure in order to add yet another IDE device.

    5) Adapter does not require driver installation in WinXP.

    Again, it is detected by device manager, it just won't appear in disc management or under My Computer.

    Info on the adapter can be found here and here.

    HDD is a Seagate. I've also tried it with a Toshiba and Western Digital, and the results are the same (if not worse).


  2. #2
    They call me the Hunted foxyloxley's Avatar
    Join Date
    Nov 2003
    3rd Rock from Sun
    I think this could be my problem -- I already have numerous IDE devices installed (one DVD writer, one CD-ROM, 2 HDDs (one slaved to the other), floppy drive, and zip drive. I've read that perhaps there's something special I have to configure in order to add yet another IDE device
    if you've attached it via USB, doesn't it get 'seen' as a USB, and not as IDE ?
    As a check, have you tried to power off, attach the HDD / USB device to the PC, and THEN power on ??
    See if it is accepted that way ?
    55 - I'm fiftyfeckinfive and STILL no wiser,
    OLDER yes
    Beware of Geeks bearing GIF's
    come and waste the day :P at The Taz Zone

  3. #3
    Right turn Clyde Nokia's Avatar
    Join Date
    Aug 2003
    Button Moon
    If you are trying to configure it as an IDE device it wont work as the maximum number of IDE devices you can have on one controller is four.

    IE, DVD rewritter, cd rom and two Hard drives ont the one IDE controller.

    Then your flopy and zip on the other.

    You can add a PCI IDE adaptor card to get more IDE devices.

    Not sure about the usb to ide adaptor as I have never seen one before but am i right in thinking that it is a USB card that then connects to the IDE bus internally?
    Drugs have taught an entire generation of kids the metric system.


  4. #4
    Senior Member
    Join Date
    Oct 2001
    Are you sure disk management doesn't see it? Because until you can see it there, everything you will be doing will be towards getting disk management to see it...

    Try booting your computer with the USB HDD unplugged, and plug it in after logging in. It should become successfully added. Then unplug it. If your computer reboots automatically upon doing this, it is likely a driver issue or a low-level USB issue. Yes, I have seen it happen before. Anyways, if it worked, it should complain about unsafe removal. Then plug it back in and see if it is detected. That sometimes worked for me with some CF card readers...

    If that didn't work, try this:

    Start -> Run -> "mmc"
    Console -> Add/Remove Snap-In
    Click "Add" -> Select "Removeable Storage Management" -> Add it
    Click Okay, and explore that snap-in such as going through "Media Pools" and "Physical Locations"
    Play around, hopefully pull something off
    That's about all I can think of...

    BTW, it might not hurt to borrow a removeable HDD from a friend to see if theirs works. Your controller could be fubarred, or the IDE-USB connection/controller has some problems. I've run into that problem once, was a PITA to figure out...

  5. #5
    No luck. I got the hardware added icon in my system tray after I plugged the drive into USB after logging in (after reboot). However, it still did not appear in My Computer. When I unplugged it, it neither gave me an unsafe removal warning nor rebooted; it just made the usual unplug sound and never gave me a message.

    The drive does not appear in the MMC snap-in.

  6. #6
    Join Date
    Jul 2005
    Am just wondering if an external harddisk on USB isn't similar to e.g. a flash memory pen or a flashcard-reader. That it's an IDE disk should not even matter since the operating system just sees it as an USB device. Either it's a hardware failure in the adapter or something else is going wrong. But I don't think it's related to any IDE setting on your computer.

  7. #7
    Join Date
    Nov 2003
    Can you hear the disk?

  8. #8
    Indeed, I forgot to mention that -- I can indeed hear the disk running when I power it up, so it appears to be running just fine, whirring quite nicely.

  9. #9
    Join Date
    Nov 2003
    I must confess I've never owned or used an external HDD. But have you messed around in your BIOS to see what options might clue you into something? And one more question. Have you had this working on another computer before?

  10. #10
    Senior Member
    Join Date
    Oct 2001
    I came across a quick mention in the DansData article you linked...

    As long as the drive you're connecting to is set to Master (does anyone else remember the days when some drives didn't have jumper block settings on their spec stickers? Wasn't that fun?), the data side is plug-and-go. The power side's about as simple; the R-Driver power adapter is a world-compatible unit, and it's got a standard IEC socket on it, so you can use any spare computer power lead you've got lying around to run it.
    So incase you haven't check that yet, be sure to do so. I think I've run into this problem once with my IDE-USB enclosures. It was a PITA to troubleshoot, and I never managed to solve it (though now I'm convinced that is what was wrong) and it had the same symptoms you mentioned.

    Cheers & good luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts