using an "old version" of any firewall is NEVER a good idea.

there's a reason that it's an old version.

there was a version of both tiny and agnitum, which BTW used the same engine, that were vulnerable to a buffer overflow that allowed a remote attacker to take complete control of a victims (you) computer. a version after that was subject to a DoS that had the engine close allowed all traffic with no restrictions.

now i dont know if the version your using is one of these but i can guarante you if there's a way to use a vulnerability some kiddie will and if an old firewall engine has HAS been found.