linux boot parameter not working
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: linux boot parameter not working

  1. #1
    Senior Member
    Join Date
    Oct 2004
    Posts
    172

    linux boot parameter not working

    i've been trying to get my framebuffer working for a while with my 2.6.10 kernel on slackware. i've gotten it setup using the vesafb driver, but i can also use another fb driver called intelfb because i have an intel graphics card. anyway, vesafb is compiled into the kernel, intelfb is a module. after asking around, i was told by several people that in order to use a different fb driver, such as intelfb, i would have to issue the "video=intelfb" boot parameter(i assume the "automatic kernel module loading" is used to load the module). the problem that i'm having is that this boot parameter doesn't do anything. nothing happens when i enter it at boot, i might as well be entering yes=no as a boot parameter . i've tried putting it in lilo.conf, but lilo complains that "video is an unrecognized token". this parameter didn't work on the stock kernel that came with slackware either(2.4.31 i think). i dont see it in "man bootparam". anybody know whats up here?

  2. #2
    Senior Member
    Join Date
    Jul 2003
    Posts
    813
    You need to read up on making an initramd that will contain the necessary bytecode. Module loading happens later on in the boot process so your framebuffer would kick in pretty late. I'm not sure what you have to do on slackware, read up their documentation and see what scripts you're given. The only thing I have on the matter is for Gentoo

    http://forums.gentoo.org/viewtopic.php?t=49036

    and there's another thread for using gensplash around there somewhere. I'm not sure if Slack has a channel on freenode [irc.freenode.net].

    Cheers!
    /\\

  3. #3
    Leftie Linux Lover the_JinX's Avatar
    Join Date
    Nov 2001
    Location
    Beverwijk Netherlands
    Posts
    2,534
    Since you are doing this on slackware,
    you might as well read the official slackware info on this..

    it's on your second CD in
    /testing/packages/linux-2.6.13/README.initrd

    or for example here: ftp://dl.xs4all.nl/pub/mirror/slackw.../README.initrd

    The usual reason to use an initrd is because you need to load kernel
    modules before mounting the root partition. Usually these modules are
    required to support the filesystem used by the root partition (ext3,
    reiserfs, xfs), or perhaps the controller that the hard drive is attached
    to (SCSI, RAID, etc). Essentially, there are so many different options
    available in modern Linux kernels that it isn't practical to try to ship
    many different kernels to try to cover everyone's needs. It's a lot more
    flexible to ship a generic kernel and a set of kernel modules for it. The
    generic 2.6 kernel in Slackware supports the ext2 filesystem (which is
    used by the initrd), and also supports most IDE controllers (much like the
    old bare.i kernel). So, if you have an IDE based system that uses the
    ext2 filesystem, then you will not need to use an initrd to boot.
    Otherwise, read on.
    in your case that would mean something like
    Code:
    mkinitrd -c -k 2.6.10 -m intelfb
    and something like
    Code:
    # Linux bootable partition config begins
    image = /boot/vmlinuz-slinky-2.6.10
      initrd = /boot/initrd.gz
      root = /dev/hda1
      label = linux-slinky
      read-only
    # Linux bootable partition config ends
    in your lilo.conf

    I don't think an initrd should be needed for video..

    I never used it except for some weird sata raid card..
    ASCII stupid question, get a stupid ANSI.
    When in Russia, pet a PETSCII.

    Get your ass over to SLAYRadio the best station for C64 Remixes !

  4. #4
    Senior Member
    Join Date
    Jul 2003
    Posts
    813
    Originally posted here by the_JinX
    I don't think an initrd should be needed for video..
    That's pretty much the only thing that goes into the initrd for framebuffers though since you need this to be able to enable the higher resolution modes.

    I suppose USB drivers could be loaded in case you needed to boot from an external USB harddrive/pendrive? Didn't try it though.
    /\\

  5. #5
    Senior Member
    Join Date
    Oct 2004
    Posts
    172
    thanks for the tip on using initrd, but what i'm starting to get concerned about is that the video parameter is just not working. i've tried compiling a driver that should definitely work, vga16fb, directly into the kernel and issuing this at the lilo prompt:
    Code:
    boot: newkernel video=vga16fb
    and it uses vesafb. i cant find any evidence from dmesg or /proc/fb that it even attempted to use vga16fb instead, so it seems to be just ignoring this parameter. there's a document in /usr/src/linux/Documentation that says the video= parameter wont work unless the kernel has framebuffer support, but mine definitely does, i can see the tux logo and everything.

  6. #6
    Senior Member
    Join Date
    Jul 2003
    Posts
    813
    Umm I don't want to sound dumb but... do you have an image somewhere too? In the initrd is where I know it usually resides [since the filesystems aren't mounted yet]. I mean if you get Tux than the video mode should be enabled but you miss the background picture.
    /\\

  7. #7
    Senior Member
    Join Date
    Oct 2004
    Posts
    172
    what background picture? i'm not using bootsplash or anything.

  8. #8
    Senior Member
    Join Date
    Jul 2003
    Posts
    813
    Well then I'm not following something along, if you get the Tux logo it means you're in the 'advanced' video mode where you have a resolution, not the standard 80 column display... So I would suppose right now it's working. For a framebuffer you can still have a background that stays with you all throughout the sessions [unlike the bootsplash which is just... a boot splash screen ].

    Examples:

    1. http://www.cyrix.dk/img/framebuffer.jpg
    2. http://www.cs.utexas.edu/~danb/screenshots/fb1.png

    So what are we missing here?
    /\\

  9. #9
    Leftie Linux Lover the_JinX's Avatar
    Join Date
    Nov 2001
    Location
    Beverwijk Netherlands
    Posts
    2,534
    ah.. yeah.. now I remember..
    yeah.. I did use initrd for video in the past..

    Oh.. and if you realy want to pimp your boot, get an animated lilo http://www.gamers.org/~quinet/lilo/
    Well, patching a newer lilo verision would be beter (I've seen some on linuxpackages a while ago)..

    thx for sparking my mem, hypronix
    ASCII stupid question, get a stupid ANSI.
    When in Russia, pet a PETSCII.

    Get your ass over to SLAYRadio the best station for C64 Remixes !

  10. #10
    Senior Member
    Join Date
    Oct 2004
    Posts
    172
    yeah. basically the problem is that i cant make anything happen with the video= boot parameter. i should be able to issue something like this at startup
    Code:
    boot: newkernel video=vesa: off
    to turn vesa off and use regular text mode. this doesn't work, it loads vesafb anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •