Linux problem-Please help
Results 1 to 6 of 6

Thread: Linux problem-Please help

  1. #1
    Junior Member black_v's Avatar
    Join Date
    Apr 2003
    Posts
    14

    Linux problem-Please help

    Hi!
    I'm using Suse Prof. 9.3.The problem I'm facing is with my win partition .
    It's mounted read-only even when i'm loged in as root.
    I am looking for a shell command to give me write permission on it(as root of course).
    I've tried under KDE but can't find a tool with GUI that can do this.Not even when I'm loged in as root.
    Thanks!

    I code,therefore I exist
    although the Gods don\'t agree
    No lightning pls

  2. #2
    Shrekkie Reloaded Raiden's Avatar
    Join Date
    Oct 2005
    Posts
    1,115
    Is it ntfs on your windows partition ? If so, does your kernel have ntfs-write enabled ?
    if its not enabled you can only mount it read-only, and even if it is, mounting ntfs read-write still can be a pain, but if its enabled you can add following line to your /etc/fstab :

    Code:
    /dev/hdax        /mnt/mountpoint     ntfs        rw,fmask=777         1   0
    If its a fat32 partition you prolly will have more luck, try adding this :

    Code:
    /dev/hdax        /mnt/mountpoint     vfat        rw,fmask=777         1   0
    where of course /dev/hdax should be the partition where your win is on, and /mnt/mountpoint the dir where you mount it in. If you added one of these lines, you can go and mount it.

    Mount everything in /etc/fstab
    Code:
    #mount -a
    See whats currently mounted and where
    Code:
    #mount

    Hope this helps,

  3. #3
    Junior Member black_v's Avatar
    Join Date
    Apr 2003
    Posts
    14
    It's NTFS.I'll still have to check about the ntfs write enabled option beacuase I'm not sure.
    Thanks!

    I code,therefore I exist
    although the Gods don\'t agree
    No lightning pls

  4. #4
    Shrekkie Reloaded Raiden's Avatar
    Join Date
    Oct 2005
    Posts
    1,115
    try this :

    Code:
    raiden@S05013:~$ cat /usr/src/linux/.config | grep NTFS
    CONFIG_NTFS_FS=y
    CONFIG_NTFS_DEBUG=y
    CONFIG_NTFS_RW=y
    where /usr/src/linux is your kernel-directory. Post your output.
    Besides the fmask=777 will make everything on your win-partition read-write, for everyone.
    if you have a problem with that i suggest you use fmask=020 or something alike.

  5. #5
    Senior Member gore's Avatar
    Join Date
    Oct 2002
    Location
    Michigan
    Posts
    7,177
    You need to install the NTFS tools from the DVDs or CDs.

  6. #6
    Junior Member black_v's Avatar
    Join Date
    Apr 2003
    Posts
    14
    It's working!
    Thanks guys!

    I code,therefore I exist
    although the Gods don\'t agree
    No lightning pls

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •