Metasploit 3.0 released!
Results 1 to 6 of 6

Thread: Metasploit 3.0 released!

  1. #1
    Senior Member Deeboe's Avatar
    Join Date
    Nov 2005
    Posts
    185

    Metasploit 3.0 released!

    Hello,

    The first Alpha version of Metasploit 3.0 was released today!!

    From the website:

    The primary goals of the 3.0 branch are listed below:

    - Improve automation of exploitation through scripting
    - Simplify the process of writing an exploit
    - Increase code re-use between exploits
    - Improve and generically integrate evasion techniques
    - Support automated network discovery and event correlation through recon modules
    - Continue to provide a friendly outlet cutting edge exploitation technology
    Find more info here: http://www.metasploit.org/projects/Framework/msf3/

    -Deeboe
    If you know the enemy and know yourself, you need not fear the result of a hundred battles. If you know yourself but not the enemy, for every victory gained you will also suffer a defeat. If you know neither the enemy nor yourself, you will succumb in every battle.
    - Sun Tzu, The Art of War

    http://tazforum.**********.com/

  2. #2
    Master-Jedi-Pimps0r & Moderator thehorse13's Avatar
    Join Date
    Dec 2002
    Location
    Washington D.C. area
    Posts
    2,883
    Careful, as you stated, this release is alpha code. Unexpected results may occur.

    I always warn folks of the release status and typically announce only GA builds.

    --TH13
    Our scars have the power to remind us that our past was real. -- Hannibal Lecter.
    Talent is God given. Be humble. Fame is man-given. Be grateful. Conceit is self-given. Be careful. -- John Wooden

  3. #3
    Senior Member Deeboe's Avatar
    Join Date
    Nov 2005
    Posts
    185
    Indeed! Good point.

    This is from an announcement on the relase:

    This is an *alpha release*, expect things to break, crash, and generally not work very well. This version is being released to gather feedback from the community and to weed out the major bugs before entering the true beta period. There are many features that have not been completely implemented at this point and there are still some edges that will need to be smoothed out prior to the final release. A few major features are not implemented, ncluding msfweb's exploit mode, some levels of session interaction, and the more user-friendly scripting APIs.
    Thanks for the heads up horse!

    -Deeboe
    If you know the enemy and know yourself, you need not fear the result of a hundred battles. If you know yourself but not the enemy, for every victory gained you will also suffer a defeat. If you know neither the enemy nor yourself, you will succumb in every battle.
    - Sun Tzu, The Art of War

    http://tazforum.**********.com/

  4. #4
    Senior Member
    Join Date
    Jun 2003
    Posts
    188
    sob sob , now will have to learn ruby.

  5. #5
    Super Moderator
    Know-it-All Master Beaver

    Join Date
    Jan 2003
    Posts
    3,914
    Hey Hey,

    The alpha is definately not without flaw either..

    colinux:~/framework-3.0-alpha-r1# ls
    README documentation modules msfd msfpayload tools
    VERSION external msfcli msfencode msfweb
    data lib msfconsole msfopcode plugins
    colinux:~/framework-3.0-alpha-r1# ./msfcli
    ./lib/rex/proto/smb/crypt.rb:1:in `require': no such file to load -- openssl (LoadError)
    from ./lib/rex/proto/smb/crypt.rb:1
    from ./lib/rex/proto/smb.rb:4
    from ./lib/rex/proto.rb:2
    from ./lib/rex.rb:43
    from ./msfcli:10
    I know for a fact that I have a working copy of openssl on here... I'll have to play with it later as I don't have time right now (damn working getting in the way of my playing)..

    When I have success later I'll post what happened.

    Peace,
    HT
    IT Blog: .:Computer Defense:.
    PnCHd (Pronounced Pinched): Acronym - Point 'n Click Hacked. As in: "That website was pinched" or "The skiddie pinched my computer because I forgot to patch".

  6. #6
    Junior Member
    Join Date
    Nov 2002
    Location
    in my head
    Posts
    1
    you need the ruby bindings to it. From Synaptic (easier for me) I looked up all packages with ruby in their name...installed some that I thought I needed, then it worked.
    Can't tell you which package fixed this because I installed quite a few packages.

    msfconsole
    <snip>logo</snip>
    =[ msf v3.0-beta-dev
    + -- --=[ 116 exploits - 99 payloads
    + -- --=[ 17 encoders - 4 nops
    =[ 17 aux

    msf >

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •